aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-09 14:09:57 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-09 14:12:41 -0800
commit198ced43fdaf50dc9672f6f70eb4c6440d60b4ff (patch)
tree1352d467bd4bdc72047d75e4910e7d7868573c2d
parenta38f09783189a9c368d39bacd9fc18abc6416437 (diff)
downloadopenembedded-198ced43fdaf50dc9672f6f70eb4c6440d60b4ff.tar.gz
apex-env_1.5.14.bb: Fix compile error discovered with gcc 4.5
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/apex/apex-env_1.5.14.bb3
-rw-r--r--recipes/apex/files/invalid-conversion.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/apex/apex-env_1.5.14.bb b/recipes/apex/apex-env_1.5.14.bb
index 38a8960e4c..896d8d1345 100644
--- a/recipes/apex/apex-env_1.5.14.bb
+++ b/recipes/apex/apex-env_1.5.14.bb
@@ -3,10 +3,11 @@ SECTION = "misc"
PRIORITY = "optional"
HOMEPAGE = "http://wiki.buici.com/twiki/bin/view/Main/ApexBootloader"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.buici.com/pub/apex/apex-${PV}.tar.gz \
file://find-apex-partition.patch \
+ file://invalid-conversion.patch \
"
S = ${WORKDIR}/apex-${PV}/usr
diff --git a/recipes/apex/files/invalid-conversion.patch b/recipes/apex/files/invalid-conversion.patch
new file mode 100644
index 0000000000..496d0d453b
--- /dev/null
+++ b/recipes/apex/files/invalid-conversion.patch
@@ -0,0 +1,13 @@
+Index: usr/link.cc
+===================================================================
+--- usr/link.cc
++++ usr/link.cc
+@@ -232,7 +232,7 @@ static struct descriptor parse_region (c
+ struct descriptor d;
+ memset (&d, 0, sizeof (d));
+
+- char* pch;
++ const char* pch;
+ if ((pch = index (sz, ':'))) {
+ int c = pch - sz;
+ if (c > sizeof (d.driver) - 1)