aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Sorokin <sorokin@altell.ru>2010-03-05 20:12:21 +0300
committerRoman I Khimov <khimov@altell.ru>2010-04-23 23:01:12 +0400
commit241a98e1771cdf4037b4534be67dcdba01e066d5 (patch)
tree8b7fccb19e5c37cea2f0e11f5113efc39237edb3
parent5ef19cb7290901839b2263fc2579327ece73fa09 (diff)
downloadopenembedded-241a98e1771cdf4037b4534be67dcdba01e066d5.tar.gz
perl: undef 'futimes' for uclibc build
Function 'futimes' doesn't exist in uClibc. Signed-off-by: Vladimir Sorokin <sorokin@altell.ru> Signed-off-by: Roman I Khimov <khimov@altell.ru>
-rw-r--r--recipes/perl/perl_5.10.1.bb3
-rw-r--r--recipes/perl/perl_5.8.8.bb3
2 files changed, 4 insertions, 2 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 7c8ff2648c..b998afde37 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r1"
+PR = "r2"
# Not tested enough
DEFAULT_PREFERENCE = "-1"
@@ -65,6 +65,7 @@ do_configure() {
# Fixups for uclibc
if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
+ -e "s,\(d_futimes=\)'define',\1'undef',g" \
-e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
-e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
-e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 2019ea6e03..3dae957e1a 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r31"
+PR = "r32"
# Major part of version
PVM = "5.8"
@@ -70,6 +70,7 @@ do_configure() {
# Fixups for uclibc
if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
+ -e "s,\(d_futimes=\)'define',\1'undef',g" \
-e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
-e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
-e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \