aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-05-09 21:21:39 +0200
committerMichael Lippautz <michael.lippautz@gmail.com>2010-05-09 22:36:29 +0200
commit70a0906ed92de60174829e421082dac51d7a64f2 (patch)
tree9a03b42aa15836058f482d845c0c28a7d66405ca
parent9524d4aa5620a75999f74244b6beb0b51200f321 (diff)
downloadopenembedded-70a0906ed92de60174829e421082dac51d7a64f2.tar.gz
libexif: Switched to .inc file based recipe.
* Added gettext as build dep. Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
-rw-r--r--recipes/libexif/libexif.inc16
-rw-r--r--recipes/libexif/libexif_0.6.16.bb19
-rw-r--r--recipes/libexif/libexif_0.6.17.bb19
3 files changed, 20 insertions, 34 deletions
diff --git a/recipes/libexif/libexif.inc b/recipes/libexif/libexif.inc
new file mode 100644
index 0000000000..9284d19edf
--- /dev/null
+++ b/recipes/libexif/libexif.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+HOMEPAGE = "http://sourceforge.net/projects/libexif"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "gettext"
+INC_PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
+
+inherit autotools
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_configure_append() {
+ sed -i s:doc\ binary:binary:g Makefile
+}
diff --git a/recipes/libexif/libexif_0.6.16.bb b/recipes/libexif/libexif_0.6.16.bb
index 20ebc71984..3fa9fd5be3 100644
--- a/recipes/libexif/libexif_0.6.16.bb
+++ b/recipes/libexif/libexif_0.6.16.bb
@@ -1,21 +1,6 @@
-DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
-HOMEPAGE = "http://sourceforge.net/projects/libexif"
-SECTION = "libs"
-LICENSE = "LGPL"
+require libexif.inc
-SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
-
-inherit autotools
-
-do_configure_append() {
- sed -i s:doc\ binary:binary:g Makefile
-}
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-do_stage() {
- autotools_stage_all
-}
+PR = "${INC_PR}.0"
SRC_URI[md5sum] = "deee153b1ded5a944ea05d041d959eca"
SRC_URI[sha256sum] = "db6885d5e40e3a273ff8bb9708ab739c8ace3c5abdd75509eec8ea31a31aac43"
diff --git a/recipes/libexif/libexif_0.6.17.bb b/recipes/libexif/libexif_0.6.17.bb
index 5b52092c0f..4acd35af86 100644
--- a/recipes/libexif/libexif_0.6.17.bb
+++ b/recipes/libexif/libexif_0.6.17.bb
@@ -1,21 +1,6 @@
-DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
-HOMEPAGE = "http://sourceforge.net/projects/libexif"
-SECTION = "libs"
-LICENSE = "LGPL"
+require libexif.inc
-SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
-
-inherit autotools
-
-do_configure_append() {
- sed -i s:doc\ binary:binary:g Makefile
-}
-
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-do_stage() {
- autotools_stage_all
-}
+PR = "${INC_PR}.1"
SRC_URI[md5sum] = "f7cf4e623a48c9a3b13f7f95f0a41015"
SRC_URI[sha256sum] = "dceb9355b148a8ee6aa96e3dff82a06c066c81e6ab18c190c946ed3b30fc7353"