aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-11-25 10:59:26 +1030
committerKhem Raj <raj.khem@gmail.com>2010-11-24 22:42:18 -0800
commita1bba89847bac62d1cbfe28e3b8059f0fcafa7d1 (patch)
tree05b99b360de3326951d475fa95fd64a2dcc507b0
parentb86e4f9c8757cf2379836a3b500480771693ee20 (diff)
downloadopenembedded-a1bba89847bac62d1cbfe28e3b8059f0fcafa7d1.tar.gz
Remove use of ipkg{,-collateral,-link}.
No one should be using these any longer. * Opkg conflicts with ipkg. * There is opkg, opkg-collateral and ipkg-utils contains ipkg-link. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/images/openprotium-image.bb2
-rw-r--r--recipes/images/opie-image-16mb.bb1
-rw-r--r--recipes/images/x11-jvm-image.bb3
-rw-r--r--recipes/opkg/opkg-ipkg-compat.bb19
-rw-r--r--recipes/opkg/opkg.inc3
-rw-r--r--recipes/tasks/task-openprotium.bb3
-rw-r--r--recipes/tasks/task-sdk-sbox-gpe.bb3
-rw-r--r--recipes/tasks/task-shr-feed.bb3
8 files changed, 6 insertions, 31 deletions
diff --git a/recipes/images/openprotium-image.bb b/recipes/images/openprotium-image.bb
index 0f64ba2052..3c31a8030a 100644
--- a/recipes/images/openprotium-image.bb
+++ b/recipes/images/openprotium-image.bb
@@ -22,7 +22,7 @@ IMAGE_PREPROCESS_COMMAND += "echo /dev/md >> ${IMAGE_ROOTFS}/etc/udev/mount.blac
IMAGE_PREPROCESS_COMMAND += "echo /dev/hd >> ${IMAGE_ROOTFS}/etc/udev/mount.blacklist;"
IMAGE_PREPROCESS_COMMAND += "echo /dev/mtd3 0x30000 0x10000 0x10000 > ${IMAGE_ROOTFS}/etc/fw_env.config;"
-ROOTFS_POSTPROCESS_COMMAND += "ipkg-cl ${IPKG_ARGS} -force-depends \
+ROOTFS_POSTPROCESS_COMMAND += "opkg-cl ${IPKG_ARGS} -force-depends \
remove ${PACKAGE_REMOVE};"
inherit image concatenated-image
diff --git a/recipes/images/opie-image-16mb.bb b/recipes/images/opie-image-16mb.bb
index b4a0e03e16..8569e952a7 100644
--- a/recipes/images/opie-image-16mb.bb
+++ b/recipes/images/opie-image-16mb.bb
@@ -4,7 +4,6 @@ DEPENDS = "task-boot task-opie-16mb"
ANGSTROM_EXTRA_INSTALL ?= ""
IMAGE_INSTALL = "task-boot \
- ipkg ipkg-collateral \
dropbear \
task-opie-16mb-base \
task-opie-16mb-applets \
diff --git a/recipes/images/x11-jvm-image.bb b/recipes/images/x11-jvm-image.bb
index fd0e5f09ad..9fed202aea 100644
--- a/recipes/images/x11-jvm-image.bb
+++ b/recipes/images/x11-jvm-image.bb
@@ -19,9 +19,6 @@ ADD_JVM = "\
jamvm \
cacao "
-ADD_OTHER = "\
- ipkg "
-
IMAGE_INSTALL = "\
${XSERVER} \
task-base-extended \
diff --git a/recipes/opkg/opkg-ipkg-compat.bb b/recipes/opkg/opkg-ipkg-compat.bb
deleted file mode 100644
index 837b02c11b..0000000000
--- a/recipes/opkg/opkg-ipkg-compat.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Files to make opkg and ipkg coexist"
-RDEPENDS_${PN} = "opkg ipkg ipkg-collateral"
-
-PR = "r1"
-PACKAGE_ARCH = "all"
-
-do_compile() {
- :
-}
-
-
-do_install () {
- install -d ${D}${sysconfdir}
- install -d ${D}/var/lib/ipkg
- ln -sf ${sysconfdir}/ipkg.conf ${D}${sysconfdir}/opkg.conf
- ln -sf ${sysconfdir}/ipkg/ ${D}${sysconfdir}/opkg
- ln -sf /var/lib/ipkg ${D}/var/lib/ipkg
-}
-
diff --git a/recipes/opkg/opkg.inc b/recipes/opkg/opkg.inc
index ae1622a6fa..0d846269c2 100644
--- a/recipes/opkg/opkg.inc
+++ b/recipes/opkg/opkg.inc
@@ -4,7 +4,8 @@ SECTION = "base"
LICENSE = "GPLv2"
SRCREV = ${OPKG_SRCREV}
PV = "0.1.8+svnr${SRCPV}"
-INC_PR = "r2"
+CONFLICTS = "ipkg"
+INC_PR = "r3"
SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
file://configure \
diff --git a/recipes/tasks/task-openprotium.bb b/recipes/tasks/task-openprotium.bb
index 1cfc740154..796d8c00ea 100644
--- a/recipes/tasks/task-openprotium.bb
+++ b/recipes/tasks/task-openprotium.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Basic image for openprotium"
HOMEPAGE = "http://www.openprotium.org"
ALLOW_EMPTY = "1"
-PR = "r3"
+PR = "r4"
inherit task
DISTRO_SSH_DAEMON ?= "dropbear"
@@ -36,7 +36,6 @@ RDEPENDS_${PN} = " kernel \
update-modules \
module-init-tools \
modutils-initscripts \
- ipkg-collateral ipkg ipkg-link \
portmap \
util-linux-ng-blkid \
mdadm \
diff --git a/recipes/tasks/task-sdk-sbox-gpe.bb b/recipes/tasks/task-sdk-sbox-gpe.bb
index 8daca11a46..315bddbf24 100644
--- a/recipes/tasks/task-sdk-sbox-gpe.bb
+++ b/recipes/tasks/task-sdk-sbox-gpe.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SDK task for Scratchbox rootstraps incuding GPE/GTK bits"
-PR = "r1"
+PR = "r2"
LICENSE = "MIT"
ALLOW_EMPTY = "1"
@@ -11,7 +11,6 @@ RDEPENDS_${PN} = "\
gdk-pixbuf-loader-xpm \
intltool \
intltool-dev \
- ipkg \
ipkg-utils \
gettext-dev \
pkgconfig-dev \
diff --git a/recipes/tasks/task-shr-feed.bb b/recipes/tasks/task-shr-feed.bb
index 2e5106ae18..5be3efff53 100644
--- a/recipes/tasks/task-shr-feed.bb
+++ b/recipes/tasks/task-shr-feed.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "SHR Feed"
-PR = "r84"
+PR = "r85"
PV = "1.0"
LICENSE = "GPL"
@@ -79,7 +79,6 @@ RDEPENDS_${PN} += "\
mtpaint \
telepathy-python \
intone-video \
- ipkg-link \
ipkg-utils \
mysql \
fltk-chess \