aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2011-03-13 15:32:48 +0100
committerSteffen Sledz <sledz@dresearch-fe.de>2011-07-28 15:04:44 +0200
commitfea2b9a83b1bfa0a9d93c9187386f71711e824af (patch)
tree8e155cb5e468801f0eee974964975ff612824985
parentfc554223813e21a49aab513f63ec2ab4059573bf (diff)
downloadopenembedded-fea2b9a83b1bfa0a9d93c9187386f71711e824af.tar.gz
apr-util: add 1.3.10
Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/apr/apr-util_1.3.10.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/apr/apr-util_1.3.10.bb b/recipes/apr/apr-util_1.3.10.bb
new file mode 100644
index 0000000000..ee32ddde41
--- /dev/null
+++ b/recipes/apr/apr-util_1.3.10.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Apache Portable Runtime (APR) companion library"
+SECTION = "libs"
+DEPENDS = "apr expat gdbm"
+LICENSE = "Apache License, Version 2.0"
+
+PR = "r0"
+
+SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
+ file://configfix.patch \
+ file://configure_fixes.patch"
+
+EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
+ --with-dbm=gdbm \
+ --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
+ --without-sqlite2 \
+ --without-sqlite3 \
+ --without-pgsql \
+ --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
+
+SRC_URI[md5sum] = "82acd25cf3df8c72eba44eaee8b80c19"
+SRC_URI[sha256sum] = "7c37ac40b2351bfc23000fb6b7b54a67e0872255df315c82eb60c821bcef4b23"
+
+inherit autotools lib_package binconfig
+
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
+do_configure_prepend() {
+ cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
+ echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
+}
+
+do_configure_append() {
+ sed -i -e s:apr_builders=/usr/share/build-1:apr_builders=${STAGING_DATADIR}/build-1:g ${S}/build/rules.mk
+ sed -i /^LIBTOOL/d ${S}/build/rules.mk
+ echo LIBTOOL="${HOST_SYS}-libtool --tag=CC" >> ${S}/build/rules.mk
+}