aboutsummaryrefslogtreecommitdiffstats
path: root/classes/autotools.bbclass
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-18 01:52:40 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-18 01:52:40 +0000
commit0f235b0f42575bfb50dd891cf44aa08c2e404a67 (patch)
tree280012a23de1185e7b135d5a033c60afed8589d3 /classes/autotools.bbclass
parent2650645237555cc24c532a4c9ccd81d8c01bcaf7 (diff)
downloadopenembedded-0f235b0f42575bfb50dd891cf44aa08c2e404a67.tar.gz
openembedded-0f235b0f42575bfb50dd891cf44aa08c2e404a67.tar.bz2
openembedded-0f235b0f42575bfb50dd891cf44aa08c2e404a67.zip
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/17 19:52:39-06:00 ti.com!kergoth Kill off the dyn-ldconfig patch for uclibc cvs, as the patch was accepted upstream. 2005/01/17 19:48:04-06:00 ti.com!kergoth Update the patcher-native build to set PATCHCMD, in case we want to actually apply patches to it at some point. 2005/01/17 19:45:23-06:00 ti.com!kergoth Add quilt-native and use quilt instead of patcher by default. BKrev: 41ec6be8oJA-Iu3VSh3tCDGFhr_Xkw
Diffstat (limited to 'classes/autotools.bbclass')
-rw-r--r--classes/autotools.bbclass146
1 files changed, 146 insertions, 0 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index e69de29bb2..820400680f 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -0,0 +1,146 @@
+inherit base
+
+def autotools_dep_prepend(d):
+ import bb;
+
+ if bb.data.getVar('INHIBIT_AUTOTOOLS_DEPS', d, 1):
+ return ''
+
+ pn = bb.data.getVar('PN', d, 1)
+ deps = ''
+
+ if pn in ['autoconf-native', 'automake-native']:
+ return deps
+ deps += 'autoconf-native automake-native '
+
+ if not pn in ['libtool', 'libtool-native', 'libtool-cross']:
+ deps += 'libtool-native '
+
+ return deps + 'gnu-config-native '
+
+EXTRA_OEMAKE = ""
+DEPENDS_prepend = "${@autotools_dep_prepend(d)}"
+acpaths = "default"
+EXTRA_AUTORECONF = "--exclude=autopoint"
+
+def autotools_set_crosscompiling(d):
+ import bb
+ if not bb.data.inherits_class('native', d):
+ return " cross_compiling=yes"
+ return ""
+
+# EXTRA_OECONF_append = "${@autotools_set_crosscompiling(d)}"
+
+oe_runconf () {
+ if [ -x ${S}/configure ] ; then
+ cfgcmd="${S}/configure \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${prefix} \
+ --exec_prefix=${exec_prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF} \
+ $@"
+ oenote "Running $cfgcmd..."
+ $cfgcmd || oefatal "oe_runconf failed"
+ else
+ oefatal "no configure script found"
+ fi
+}
+
+autotools_do_configure() {
+ case ${PN} in
+ autoconf*)
+ ;;
+ automake*)
+ ;;
+ *)
+ # WARNING: gross hack follows:
+ # An autotools built package generally needs these scripts, however only
+ # automake or libtoolize actually install the current versions of them.
+ # This is a problem in builds that do not use libtool or automake, in the case
+ # where we -need- the latest version of these scripts. e.g. running a build
+ # for a package whose autotools are old, on an x86_64 machine, which the old
+ # config.sub does not support. Work around this by installing them manually
+ # regardless.
+ ( for ac in `find ${S} -name configure.in -o -name configure.ac`; do
+ rm -f `dirname $ac`/configure
+ done )
+ if [ -e ${S}/configure.in -o -e ${S}/configure.ac ]; then
+ olddir=`pwd`
+ cd ${S}
+ if [ x"${acpaths}" = xdefault ]; then
+ acpaths=
+ for i in `find ${S} -maxdepth 2 -name \*.m4|grep -v 'aclocal.m4'| \
+ grep -v 'acinclude.m4' | sed -e 's,\(.*/\).*$,\1,'|sort -u`; do
+ acpaths="$acpaths -I $i"
+ done
+ else
+ acpaths="${acpaths}"
+ fi
+ install -d ${STAGING_DIR}/${HOST_SYS}/share/aclocal
+ acpaths="$acpaths -I ${STAGING_DIR}/${HOST_SYS}/share/aclocal"
+ # autoreconf is too shy to overwrite aclocal.m4 if it doesn't look
+ # like it was auto-generated. Work around this by blowing it away
+ # by hand, unless the package specifically asked not to run aclocal.
+ if ! echo ${EXTRA_AUTORECONF} | grep -q "aclocal"; then
+ rm -f aclocal.m4
+ fi
+ if [ -e configure.in ]; then
+ CONFIGURE_AC=configure.in
+ else
+ CONFIGURE_AC=configure.ac
+ fi
+ if grep "^AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ if grep "sed.*POTFILES" configure.ac >/dev/null; then
+ : do nothing -- we still have an old unmodified configure.ac
+ else
+ oenote Executing glib-gettextize --force --copy
+ echo "no" | glib-gettextize --force --copy
+ fi
+ fi
+ if grep "^AC_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+ oenote Executing intltoolize --copy --force --automake
+ intltoolize --copy --force --automake
+ fi
+ oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
+ mkdir -p m4
+ autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
+ cd $olddir
+ fi
+ ;;
+ esac
+ if [ -e ${S}/configure ]; then
+ oe_runconf
+ else
+ oenote "nothing to configure"
+ fi
+}
+
+autotools_do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+STAGE_TEMP="${WORKDIR}/temp-staging"
+
+autotools_stage_includes() {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ make DESTDIR="${STAGE_TEMP}" install
+ cp -a ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ rm -rf ${STAGE_TEMP}
+}
+
+EXPORT_FUNCTIONS do_configure do_install