aboutsummaryrefslogtreecommitdiffstats
path: root/classes/image.bbclass
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-27 12:44:07 +0200
commit293b05335ab540c4c8402e0a5caf2886b786a318 (patch)
tree11e5a7c2dce338058f150e08d1ff47c9d4d8eccd /classes/image.bbclass
parent1ee2156592ba17f64f3c9b8970285a259730b871 (diff)
parente9aacc4ce4784c91cb4908145b8fb7b3ec8aa6e0 (diff)
downloadopenembedded-293b05335ab540c4c8402e0a5caf2886b786a318.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/testing2010
Conflicts: recipes/linux/linux-openmoko-devel_git.bb recipes/openmoko-3rdparty/pisi_0.5.2.bb recipes/openmoko-3rdparty/pisi_0.5.3.bb recipes/openmoko-3rdparty/pisi_0.5.bb recipes/uclibc/uclibc_nptl.bb
Diffstat (limited to 'classes/image.bbclass')
-rw-r--r--classes/image.bbclass18
1 files changed, 12 insertions, 6 deletions
diff --git a/classes/image.bbclass b/classes/image.bbclass
index 8e202f0665..2105195003 100644
--- a/classes/image.bbclass
+++ b/classes/image.bbclass
@@ -36,7 +36,7 @@ IMAGE_BASENAME[export] = "1"
export PACKAGE_INSTALL ?= "${IMAGE_INSTALL} ${IMAGE_BOOT}"
# We need to recursively follow RDEPENDS and RRECOMMENDS for images
-do_rootfs[recrdeptask] += "do_deploy do_populate_staging"
+do_rootfs[recrdeptask] += "do_deploy do_populate_sysroot"
# Images are generally built explicitly, do not need to be part of world.
EXCLUDE_FROM_WORLD = "1"
@@ -47,7 +47,7 @@ PID = "${@os.getpid()}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_rootfs[depends] += "makedevs-native:do_populate_staging fakeroot-native:do_populate_staging"
+do_rootfs[depends] += "makedevs-native:do_populate_sysroot fakeroot-native:do_populate_sysroot"
python () {
import bb
@@ -55,9 +55,9 @@ python () {
deps = bb.data.getVarFlag('do_rootfs', 'depends', d) or ""
for type in (bb.data.getVar('IMAGE_FSTYPES', d, True) or "").split():
for dep in ((bb.data.getVar('IMAGE_DEPENDS_%s' % type, d) or "").split() or []):
- deps += " %s:do_populate_staging" % dep
+ deps += " %s:do_populate_sysroot" % dep
for dep in (bb.data.getVar('EXTRA_IMAGEDEPENDS', d, True) or "").split():
- deps += " %s:do_populate_staging" % dep
+ deps += " %s:do_populate_sysroot" % dep
bb.data.setVarFlag('do_rootfs', 'depends', deps, d)
runtime_mapping_rename("PACKAGE_INSTALL", d)
@@ -119,8 +119,12 @@ fakeroot do_rootfs () {
mkdir -p ${IMAGE_ROOTFS}
mkdir -p ${DEPLOY_DIR_IMAGE}
+ mkdir -p ${IMAGE_ROOTFS}/etc
+
if [ "${USE_DEVFS}" != "1" ]; then
+ rm -rf ${IMAGE_ROOTFS}/etc/device_table
for devtable in ${@get_devtable_list(d)}; do
+ cat $devtable >> ${IMAGE_ROOTFS}/etc/device_table
makedevs -r ${IMAGE_ROOTFS} -D $devtable
done
fi
@@ -201,7 +205,7 @@ log_check() {
# can decide if they want it or not
zap_root_password () {
- sed 's%^root:[^:]*:%root:*:%' < ${IMAGE_ROOTFS}/etc/passwd >${IMAGE_ROOTFS}/etc/passwd.new
+ sed 's%^root:[^:]*:%root::%' < ${IMAGE_ROOTFS}/etc/passwd >${IMAGE_ROOTFS}/etc/passwd.new
mv ${IMAGE_ROOTFS}/etc/passwd.new ${IMAGE_ROOTFS}/etc/passwd
}
@@ -256,7 +260,9 @@ if [ -e ${IMAGE_ROOTFS}/usr/bin/opkg-cl ] ; then
cat /tmp/wanted-locale-packages /tmp/available-locale-packages | sort | uniq -d > /tmp/pending-locale-packages
- cat /tmp/pending-locale-packages | xargs ${OPKG} -nodeps install
+ if [ -s /tmp/pending-locale-packages ] ; then
+ cat /tmp/pending-locale-packages | xargs ${OPKG} -nodeps install
+ fi
rm -f ${IMAGE_ROOTFS}${libdir}/opkg/lists/*
for i in ${IMAGE_ROOTFS}${libdir}/opkg/info/*.preinst; do