aboutsummaryrefslogtreecommitdiffstats
path: root/classes/kernel-arch.bbclass
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-06-11 12:51:28 +0000
committerKoen Kooi <koen@openembedded.org>2007-06-11 12:51:28 +0000
commitef828c09c96cdc47f0b6901f2ee83cdb4bbcc8ec (patch)
tree4951178ef7a32bd5fbf984230aef2fd5cd22f5e7 /classes/kernel-arch.bbclass
parent55c9ddab073ec7a7e404053861dd479f260688db (diff)
downloadopenembedded-ef828c09c96cdc47f0b6901f2ee83cdb4bbcc8ec.tar.gz
Blackfin support:
* siteinfo.bbclass, bfin-common: autofoo support * kernel-arch.bbclass, linux-libc-headers_2.6.20.bb: bfin -> blackfin mapping for the kernel * insane.bbclass: stubs for bfin arch, needs proper number, but that will get reported when it encounters the first binary * uclibc: config for adsp-bf537-stamp machine * adsp-bf537-stamp.conf: machine description for adsp-bf537-stamp board (http://www.analog.com/en/prod/0%2C2877%2CBF537%25252DSTAMP%2C00.html) The build currently stops in binutils cross with the "ld not supported on this archicture" message
Diffstat (limited to 'classes/kernel-arch.bbclass')
-rw-r--r--classes/kernel-arch.bbclass5
1 files changed, 3 insertions, 2 deletions
diff --git a/classes/kernel-arch.bbclass b/classes/kernel-arch.bbclass
index 3804cd71b8..9208c3507a 100644
--- a/classes/kernel-arch.bbclass
+++ b/classes/kernel-arch.bbclass
@@ -12,7 +12,7 @@ valid_archs = "alpha cris ia64 \
m32r mips \
sh sh64 um h8300 \
parisc s390 v850 \
- avr32"
+ avr32 blackfin"
def map_kernel_arch(a, d):
import bb, re
@@ -24,7 +24,8 @@ def map_kernel_arch(a, d):
elif re.match('armeb$', a): return 'arm'
elif re.match('mipsel$', a): return 'mips'
elif re.match('sh(3|4)$', a): return 'sh'
- elif a in valid_archs: return a
+ elif re.match('bfin', a): return 'blackfin'
+ elif a in valid_archs: return a
else:
bb.error("cannot map '%s' to a linux kernel architecture" % a)