aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2011-01-12 21:05:58 +0100
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2011-01-13 22:49:28 +0100
commit15c269e4bd54aeee21b86dc6084179d1c914eeff (patch)
treec3669d61a80dec93bc4d6fd9e4b9b41246d4a5d9 /classes
parent13adc34c363416b3a850efbc11ea7e0f024122f0 (diff)
downloadopenembedded-15c269e4bd54aeee21b86dc6084179d1c914eeff.tar.gz
autotools.bbclass: use grep -q
-q is a required arg so use it instead of redirecting to /dev/null Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Rini <tom_rini@mentor.com> Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/autotools.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index 45b75dfbcf..3850ae9e48 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -160,14 +160,14 @@ autotools_do_configure() {
else
CONFIGURE_AC=configure.ac
fi
- if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
- if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
+ if grep -q "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC; then
+ if grep -q "sed.*POTFILES" $CONFIGURE_AC; then
: do nothing -- we still have an old unmodified configure.ac
else
oenote Executing glib-gettextize --force --copy
echo "no" | glib-gettextize --force --copy
fi
- else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ else if grep -q "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC; then
if [ -e ${STAGING_DATADIR}/gettext/config.rpath ]; then
cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
else
@@ -181,7 +181,7 @@ autotools_do_configure() {
done
oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
- if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+ if grep -q "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC; then
oenote Executing intltoolize --copy --force --automake
intltoolize --copy --force --automake
fi