aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2011-02-11 20:51:40 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-12 07:58:05 -0700
commitbd84493b2201c12ee29fa34e58696568f5644761 (patch)
tree091de4a806cabcfa5ec9447f82d4d8ad84ebb9ac /classes
parent96430087f97632ab59925c25a0df9148500c3911 (diff)
downloadopenembedded-bd84493b2201c12ee29fa34e58696568f5644761.tar.gz
utils.bbclass: restore previous implementation of explode_deps()
* explode_deps() changed its behavior to omit version information when the function was removed from OE in favor of BitBake's implementation in March 2010. Since then, packages didn't contain versioned runtime dependencies. See commit 89b7e433719f43f1c36c76cb8856d559014e99bc * This patch restores the previous implementation of explode_deps(), thus fixing the generation of versioned runtime dependencies. * Reimplementing explode_deps() using bb.utils.explode_dep_versions() didn't work, because it choked upon parsing inline python code, e.g. on update-modules_1.0.bb's RDEPENDS_${PN} field. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Acked-by: Chris Larson <chris_larson@mentor.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/utils.bbclass16
1 files changed, 15 insertions, 1 deletions
diff --git a/classes/utils.bbclass b/classes/utils.bbclass
index 2fa6204bfa..eea084ac3a 100644
--- a/classes/utils.bbclass
+++ b/classes/utils.bbclass
@@ -423,7 +423,21 @@ def check_app_exists(app, d):
return bool(which(path, app))
def explode_deps(s):
- return bb.utils.explode_deps(s)
+ r = []
+ l = s.split()
+ flag = False
+ for i in l:
+ if i[0] == '(':
+ flag = True
+ j = []
+ if flag:
+ j.append(i)
+ if i.endswith(')'):
+ flag = False
+ r[-1] += ' ' + ' '.join(j)
+ else:
+ r.append(i)
+ return r
def base_set_filespath(path, d):
bb.note("base_set_filespath usage is deprecated, %s should be fixed" % d.getVar("P", 1))