aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-19 19:50:41 -0700
committerChris Larson <chris_larson@mentor.com>2010-11-02 18:39:03 -0700
commit6a0a78a9dfa5898467ce96a15b138a5eb49e98d2 (patch)
tree65567ce4ab044bcdb41ce8880ef111cac512fea6 /classes
parent6e509ddf9ae266d224f136ecf2b2f83a7401df9c (diff)
downloadopenembedded-6a0a78a9dfa5898467ce96a15b138a5eb49e98d2.tar.gz
autotools: symlink where we can
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/autotools.bbclass17
1 files changed, 9 insertions, 8 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index 46d6d3dad1..7c998e4ae9 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -36,10 +36,11 @@ gnu_configize_here() {
if [ ! -e ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ]; then
oefatal "gnu-config data files missing"
fi
- oenote Updating config.sub and config.guess in $macrodir
- rm -f $macrodir/config.sub $macrodir/config.guess
- cp ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub $macrodir/config.sub
- cp ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess $macrodir/config.guess
+ oenote "Updating config.sub and config.guess in $macrodir"
+ ln -sf ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub \
+ $macrodir/config.sub
+ ln -sf ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess \
+ $macrodir/config.guess
fi
}
@@ -76,21 +77,21 @@ oe_autoreconf () {
if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
: do nothing -- we still have an old unmodified configure.ac
else
- echo "no" | glib-gettextize --force --copy
+ echo "no" | glib-gettextize --force
fi
else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
if [ -e ${STAGING_DATADIR}/gettext/config.rpath ]; then
- cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
+ ln -sf ${STAGING_DATADIR}/gettext/config.rpath ${S}/
else
oenote ${STAGING_DATADIR}/gettext/config.rpath not found. gettext is not installed.
fi
fi
mkdir -p m4
- autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} "$@" \
+ autoreconf -Wcross --verbose --install --symlink --force ${EXTRA_AUTORECONF} "$@" \
|| oefatal "autoreconf execution failed."
if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
- intltoolize --copy --force --automake
+ intltoolize --force --automake
fi
gnu_configize_here