aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2009-04-29 23:57:54 +0400
committerRoman I Khimov <khimov@altell.ru>2009-04-30 23:17:10 +0400
commitdeb50c8b70a08632e779db9ee60d3f2d655fd3aa (patch)
treec68e286d16f25275c96fce318f09227b10b3395e /classes
parent80671af8df96d008fbaf8e6cc1e0a0b819167d79 (diff)
downloadopenembedded-deb50c8b70a08632e779db9ee60d3f2d655fd3aa.tar.gz
openembedded-deb50c8b70a08632e779db9ee60d3f2d655fd3aa.tar.bz2
openembedded-deb50c8b70a08632e779db9ee60d3f2d655fd3aa.zip
coreutils-native: make mandatory dep for all packages
Gives us guaranteed sane GNU coreutils on any host. Should greatly ease support for various non-GNU host systems and allow to safely remove some other native packages like 'install-native'. Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'classes')
-rw-r--r--classes/base.bbclass6
1 files changed, 4 insertions, 2 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index e5fd814b25..270b05d11e 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -125,9 +125,11 @@ def base_dep_prepend(d):
# the case where host == build == target, for now we don't work in
# that case though.
#
- deps = "shasum-native "
- if bb.data.getVar('PN', d, True) == "shasum-native":
+ deps = "shasum-native coreutils-native"
+ if bb.data.getVar('PN', d, True) == "shasum-native" or bb.data.getVar('PN', d, True) == "stagemanager-native":
deps = ""
+ if bb.data.getVar('PN', d, True) == "coreutils-native":
+ deps = "shasum-native"
# INHIBIT_DEFAULT_DEPS doesn't apply to the patch command. Whether or not
# we need that built is the responsibility of the patch function / class, not