aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-02-19 09:26:36 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-02-19 09:26:36 +0000
commit7904f3397095b3b1d8b7eb96a10c455019a1e71b (patch)
treeeb93b6815089eb1ebc0c82a43d17f96ab7c39ab8 /classes
parent482ff00d8922c122953206660d1baac0e26cca76 (diff)
downloadopenembedded-7904f3397095b3b1d8b7eb96a10c455019a1e71b.tar.gz
classes/kernel.bbclass: fix staging for x86 on kernels >= 2.6.24
Diffstat (limited to 'classes')
-rw-r--r--classes/kernel.bbclass4
1 files changed, 4 insertions, 0 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index 6c12004dad..1e325323df 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -128,6 +128,10 @@ kernel_do_stage() {
if [ -e arch/${ARCH}/Makefile ]; then
install -d ${STAGING_KERNEL_DIR}/arch/${ARCH}
install -m 0644 arch/${ARCH}/Makefile* ${STAGING_KERNEL_DIR}/arch/${ARCH}
+ # Otherwise check arch/x86/Makefile for i386 and x86_64 on kernels >= 2.6.24
+ elif [ -e arch/x86/Makefile ]; then
+ install -d ${STAGING_KERNEL_DIR}/arch/x86
+ install -m 0644 arch/x86/Makefile* ${STAGING_KERNEL_DIR}/arch/x86
fi
cp -fR include/config* ${STAGING_KERNEL_DIR}/include/
install -m 0644 ${KERNEL_OUTPUT} ${STAGING_KERNEL_DIR}/${KERNEL_IMAGETYPE}