aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-21 13:40:17 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-21 13:40:17 +0000
commite0a191e234aebe57a84143f2b0bf170236a77f37 (patch)
treec0115b8ec012f2c68dead00484cb238ac9cebc47 /classes
parentb8f88822e375f2228652ea332257574b7c7784f5 (diff)
downloadopenembedded-e0a191e234aebe57a84143f2b0bf170236a77f37.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/21 14:13:30+01:00 local!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into marcinj.local:/home/hrw/zaurus/bb/openembedded 2005/01/21 14:13:06+01:00 local!hrw justreader: fix Settings file location (really fix #204) 2005/01/21 14:11:29+01:00 (none)!koen patch to libpcap to fix dsniff build, courtesy Bob Davies 2005/01/21 14:10:18+01:00 local!hrw transition from libstdc++ to libsupc++ Basically it allow us to drop libstdc++ dependency from some programs. Binaries are getting little bigger but don't depend on ~3.5MiB library. If your package fails during linking you have to add one line to it's .bb file: export OE_QMAKE_LINK="${CXX}" 2005/01/21 14:02:44+01:00 local!hrw we already have freedroid in meta-opie - it's in task-qpe-games as it is not from OPIE 2005/01/21 14:01:28+01:00 local!hrw disabled PARALLEL_MAKE for uae and zroadmap 2005/01/21 11:38:29+01:00 local!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into marcinj.local:/home/hrw/zaurus/bb/openembedded 2005/01/18 18:53:19+01:00 hrw.one.pl!hrw disable PARALLEL_MAKE for opie-tinykate BKrev: 41f106415qu3LUbzxrhFJByjZfa8pQ
Diffstat (limited to 'classes')
-rw-r--r--classes/palmtop.bbclass10
1 files changed, 10 insertions, 0 deletions
diff --git a/classes/palmtop.bbclass b/classes/palmtop.bbclass
index e69de29bb2..523c3d71bb 100644
--- a/classes/palmtop.bbclass
+++ b/classes/palmtop.bbclass
@@ -0,0 +1,10 @@
+# basically a placeholder for something more fancy
+# for now, just declare some things
+
+inherit qmake
+
+EXTRA_QMAKEVARS_POST_append = " DEFINES+=QWS LIBS+=-lqpe CONFIG+=qt LIBS-=-lstdc++ LIBS+=-lsupc++"
+
+DEPENDS_prepend = "virtual/libqpe uicmoc-native "
+
+FILES_${PN} = "${palmtopdir}"