aboutsummaryrefslogtreecommitdiffstats
path: root/conf/distro/include/angstrom-2007-for-openmoko.inc
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 22:57:49 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 23:11:11 +0200
commit350f068eb5aa57d363b6c32a1b7811f98b3c4e18 (patch)
tree04365702a3291eb06168245785a39179df0d4851 /conf/distro/include/angstrom-2007-for-openmoko.inc
parentd07c292757ed0773ef38e629642aa1aa15e786a9 (diff)
downloadopenembedded-holger/hash-style.tar.gz
[link] Allow to use -Wl,--as-needed when linking (idea from poky)holger/hash-style
With --as-needed the linker will only emit SO_NEEDED for the libraries that are actually required and not the one given on the command line. This can drastically reduce the number of needed libraries. Sometimes this does not work and this is where broken-as-needed.inc will collect packages that do not work with --as-needed. The current list is taken from poky. Enable this for angstrom and eglibc, glibc and uclibc as this requires a binutils version from around ~2006. Also bump the DISTRO_PR after this change.
Diffstat (limited to 'conf/distro/include/angstrom-2007-for-openmoko.inc')
-rw-r--r--conf/distro/include/angstrom-2007-for-openmoko.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/conf/distro/include/angstrom-2007-for-openmoko.inc b/conf/distro/include/angstrom-2007-for-openmoko.inc
index 0c7fe5be49..2803762a6b 100644
--- a/conf/distro/include/angstrom-2007-for-openmoko.inc
+++ b/conf/distro/include/angstrom-2007-for-openmoko.inc
@@ -11,6 +11,7 @@ DISTRO_REVISION = "51"
require conf/distro/include/sane-srcdates.inc
require conf/distro/include/sane-srcrevs.inc
+require conf/distro/include/broken-as-needed.inc
#Images built can have to modes:
# 'debug': empty rootpassword, strace included