aboutsummaryrefslogtreecommitdiffstats
path: root/conf/distro/openwrt-sdk.conf
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2008-01-09 02:34:12 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2008-01-09 02:34:12 +0000
commit67067c8bb631cd7221de861626105356ae8b6471 (patch)
tree7cb3d702a24791cdbacd4a52d6cde00cf38cb124 /conf/distro/openwrt-sdk.conf
parentd30098ac944080b44061d7697079f36d1532bdcd (diff)
downloadopenembedded-67067c8bb631cd7221de861626105356ae8b6471.tar.gz
openwrt-sdk.conf: Elaborate, tested to actually work.
* Set IPKGBUILDCMD to produce openwrt-compatible packages (tar.gz toplevel wrap instead of ar). Caveat: latest ipkg-make-index doesn't support these. Pre-latest, doesn't throw error, but generates crap still. * Added ASSUME_SHLIB for libm.
Diffstat (limited to 'conf/distro/openwrt-sdk.conf')
-rw-r--r--conf/distro/openwrt-sdk.conf5
1 files changed, 4 insertions, 1 deletions
diff --git a/conf/distro/openwrt-sdk.conf b/conf/distro/openwrt-sdk.conf
index fc760f9ea0..92e5ac5b39 100644
--- a/conf/distro/openwrt-sdk.conf
+++ b/conf/distro/openwrt-sdk.conf
@@ -18,9 +18,12 @@ require conf/distro/generic-uclibc.conf
# Header
#
DISTRO_NAME = "OpenWRT"
+DISTRO_REVISION = "2"
+
+IPKGBUILDCMD = "ipkg-build -c -o 0 -g 0"
# This is what lives in SDK
ASSUME_PROVIDED += "virtual/${TARGET_PREFIX}gcc virtual/libc"
# Make sure that we have correct package dependencies for SDK-provided libs.
-ASSUME_SHLIBS += "libc.so.0:uclibc libgcc_s.so.1:libgcc"
+ASSUME_SHLIBS += "libc.so.0:uclibc libm.so.0:uclibc libgcc_s.so.1:libgcc"