aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2011-01-26 21:02:38 -0600
committerMike Westerhof <mwester@dls.net>2011-01-26 21:02:38 -0600
commit8fe839a9faef7df6a07cd229b80b94e4cacbb9dd (patch)
tree979ebdf2eba93c4548d38add2e1e36127f25a87a /conf
parentd305d981724e098e0b246ba38aeb60b52d5dd316 (diff)
downloadopenembedded-8fe839a9faef7df6a07cd229b80b94e4cacbb9dd.tar.gz
SlugOS: slugos.inc, task-slugos.bb - Debugging improvements
Adds devshell, rootfs directory is qualified by machine and libc, and add kexec to the base image. Signed-off-by: Mike Westerhof <mike@mwester.net>
Diffstat (limited to 'conf')
-rw-r--r--conf/distro/include/slugos.inc3
1 files changed, 2 insertions, 1 deletions
diff --git a/conf/distro/include/slugos.inc b/conf/distro/include/slugos.inc
index 837e42250c..13158e1321 100644
--- a/conf/distro/include/slugos.inc
+++ b/conf/distro/include/slugos.inc
@@ -40,6 +40,7 @@ IMAGE_BASENAME = "${@['slugos${SITEINFO_ENDIANNESS}', 'ucslugc'][bb.data.getVar(
CACHE = "${TMPDIR}/cache/${LIBC}/${MACHINE}"
DEPLOY_DIR = "${TMPDIR}/deploy/${LIBC}"
+IMAGE_ROOTFS = "${TMPDIR}/rootfs/${MACHINE}-${LIBC}-${PN}"
# The following need not be set, the defaults should be adequate
#USE_NLS = "no" or "yes"
@@ -57,7 +58,7 @@ USE_NLS_glib-2.0 = "yes"
USE_NLS_glib-2.0-native = "yes"
USE_NLS_gcc-cross = "no"
-INHERIT += "package_ipk debian testlab siteinfo"
+INHERIT += "package_ipk debian testlab siteinfo devshell"
# FULL_OPTIMIZATION
# Optimization settings. Os works fine and is significantly better than O2.