aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-04-22 11:55:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-22 11:55:50 +0000
commit297fac9b424a54ec0340d8062661e2887636fb35 (patch)
treee8896d4ae2ec599e28bebe25f6cbbaa3d388d47b /conf
parent47424d46a572ce5670509b03282d64c004335833 (diff)
downloadopenembedded-297fac9b424a54ec0340d8062661e2887636fb35.tar.gz
libsdl-mixer: explicitely disable ogg/vorbis support (libraries not in DEPENDS)packages/libsdl/libsdl-mixer_1.2.6.bb
Diffstat (limited to 'conf')
-rw-r--r--conf/bitbake.conf2
-rw-r--r--conf/distro/familiar-0.8.4.conf84
-rw-r--r--conf/distro/familiar-feeds.inc24
3 files changed, 109 insertions, 1 deletions
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index cbec1b8ff1..0c179a67ca 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -291,7 +291,7 @@ export palmqtdir = "/opt/QtPalmtop"
GNU_MIRROR = "ftp://ftp.gnu.org/gnu"
DEBIAN_MIRROR = "ftp://ftp.debian.org/debian/pool"
SOURCEFORGE_MIRROR = "http://heanet.dl.sourceforge.net/sourceforge"
-GPE_MIRROR = "http://ftp.handhelds.org/pub/projects/gpe/source"
+GPE_MIRROR = "http://handhelds.org/pub/projects/gpe/source"
XLIBS_MIRROR = "http://xlibs.freedesktop.org/release"
GNOME_MIRROR = "http://ftp.gnome.org/pub/GNOME/sources"
HANDHELDS_CVS = "cvs://anoncvs:anoncvs@anoncvs.handhelds.org/cvs"
diff --git a/conf/distro/familiar-0.8.4.conf b/conf/distro/familiar-0.8.4.conf
new file mode 100644
index 0000000000..70ad4eda85
--- /dev/null
+++ b/conf/distro/familiar-0.8.4.conf
@@ -0,0 +1,84 @@
+DISTRO = "familiar"
+DISTRO_NAME = "Familiar Linux"
+DISTRO_VERSION = "v0.8.4-rc1"
+
+include conf/distro/familiar.conf
+include conf/distro/familiar-feeds.inc
+
+
+DISTRO_TYPE = "release"
+
+
+CVSDATE = 20051212
+
+PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
+PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}gcc:gcc-cross"
+PREFERRED_PROVIDERS += "virtual/${TARGET_PREFIX}g++:gcc-cross"
+
+PREFERRED_PROVIDER_virtual/libiconv=glibc
+PREFERRED_PROVIDER_virtual/libintl=glibc
+PREFERRED_PROVIDER_x11=diet-x11
+
+#newer hostap modules didn't seem to work for me
+PREFERRED_VERSION_hostap-modules ?= "0.3.9"
+
+#2.4 machines prefer 0.13e ones
+PREFERRED_VERSION_orinoco-modules ?= "0.13e"
+
+#but 0.13e doesn't build against 2.6
+PREFERRED_VERSION_orinoco-modules_h2200 ?= "0.15"
+PREFERRED_VERSION_orinoco-modules_ipaq-pxa270 ?= "0.15"
+
+#prefer a newer hh.org cvs kernel
+CVSDATE_handhelds-pxa-2.6 = "20051221"
+CVSDATE_LAB-kernel = "20051221"
+
+#The CSL compiler is unusable because
+# 1) certain programs stop to compile
+# 2) more programs segfault
+PREFERRED_VERSION_gcc ?= "3.4.4"
+PREFERRED_VERSION_gcc-cross ?= "3.4.4"
+PREFERRED_VERSION_gcc-cross-initial ?= "3.4.4"
+PREFERRED_VERSION_gcc-cross-sdk ?= "3.4.4"
+
+
+#
+# Machines section
+#
+
+# select kernel version for the zaurus family
+
+ZKERNEL_VERSION_poodle = "2.4"
+ZKERNEL_VERSION_collie = "2.4"
+ZKERNEL_VERSION_c7x0 = "2.6"
+ZKERNEL_VERSION_spitz = "2.4"
+ZKERNEL_VERSION_akita = "2.4"
+ZKERNEL_VERSION_borzoi = "2.4"
+ZKERNEL_VERSION_tosa = "2.4"
+
+
+#
+# Opie
+#
+
+PREFERRED_PROVIDERS += " virtual/libqpe:libqpe-opie"
+PREFERRED_VERSION_qte = "2.3.10"
+
+OPIE_VERSION = "1.2.1"
+include conf/distro/preferred-opie-versions.inc
+
+#
+# GPE
+#
+
+PREFERRED_PROVIDERS += "virtual/xserver:xserver-kdrive"
+PREFERRED_PROVIDERS += "virtual/gconf:gconf-dbus"
+PREFERRED_PROVIDER_x11 = "diet-x11"
+
+include conf/distro/preferred-gpe-versions-2.7.inc
+
+#
+# E
+#
+include conf/distro/preferred-e-versions.inc
+
diff --git a/conf/distro/familiar-feeds.inc b/conf/distro/familiar-feeds.inc
new file mode 100644
index 0000000000..234088246f
--- /dev/null
+++ b/conf/distro/familiar-feeds.inc
@@ -0,0 +1,24 @@
+DISTRO_FEED_PREFIX = "http://familiar.handhelds.org/releases/${DISTRO_VERSION}/feed"
+
+DISTRO_FEEDS_prepend () {
+# Familiar ${DISTRO_VERSION} feeds
+
+# base - essential packages
+src/gz base ${DISTRO_FEED_PREFIX}/base
+src/gz base-${MACHINE} ${DISTRO_FEED_PREFIX}/base/machine/${MACHINE}
+
+# updates - security and bugfix updates go in this feed
+src/gz updates ${DISTRO_FEED_PREFIX}/updates
+src/gz updates-${MACHINE} ${DISTRO_FEED_PREFIX}/updates/machine/${MACHINE}
+
+# common - additional packages not specific to any graphical environment
+src/gz common ${DISTRO_FEED_PREFIX}/common
+src/gz common-${MACHINE} ${DISTRO_FEED_PREFIX}/common/machine/${MACHINE}
+}
+
+DISTRO_LOCALE_FEEDS_PREFIXES = "${DISTRO_FEED_PREFIX}/base ${DISTRO_FEED_PREFIX}/updates ${DISTRO_FEED_PREFIX}/common"
+
+DISTRO_LOCALE_FEEDS_HEADER_prepend () {
+# Familiar ${DISTRO_VERSION} locale feeds
+
+}