aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/python
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2007-11-17 00:24:43 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2007-11-17 00:24:43 +0000
commit16ddc0d8855b835d7cf831e71b40efda56095058 (patch)
tree8683b1d0b22c3bf37aff68166597c65cb246635c /contrib/python
parent8b8154c306c5b5d6af2a0a1066a970fa550a2914 (diff)
downloadopenembedded-16ddc0d8855b835d7cf831e71b40efda56095058.tar.gz
Fix python 2.5 manifest:
* fix/simplify generate-manifest-2.5.py * add missing dependencies for python-logging (Closes: #3272) * add struct.py to python-core (Closes: #3296) * add missing files to python-crypt (Closes: #3303)
Diffstat (limited to 'contrib/python')
-rwxr-xr-xcontrib/python/generate-manifest-2.5.py98
1 files changed, 46 insertions, 52 deletions
diff --git a/contrib/python/generate-manifest-2.5.py b/contrib/python/generate-manifest-2.5.py
index 76a203a84f..1317f23b4a 100755
--- a/contrib/python/generate-manifest-2.5.py
+++ b/contrib/python/generate-manifest-2.5.py
@@ -10,7 +10,7 @@ import time
VERSION = "2.5.1"
# increase when touching python-core, this should be the same ml version as in python_2.5.1.bb
-BASEREV = 1
+BASEREV = 2
__author__ = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
__version__ = "20070823"
@@ -20,8 +20,7 @@ class MakefileMaker:
def __init__( self, outfile ):
"""initialize"""
self.packages = {}
- self.sourcePrefix = "/lib/python%s/" % VERSION[:3]
- self.targetPrefix = "${libdir}/python%s" % VERSION[:3]
+ self.targetPrefix = "${libdir}/python%s/" % VERSION[:3]
self.output = outfile
self.out( "#" * 120 )
self.out( "### AUTO-GENERATED by '%s' [(C) 2002-2007 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on %s" % ( sys.argv[0], time.asctime() ) )
@@ -39,9 +38,8 @@ class MakefileMaker:
"""print a line to the output file"""
print >> self.output, data
- def setPrefix( self, sourcePrefix, targetPrefix ):
+ def setPrefix( self, targetPrefix ):
"""set a file prefix for addPackage files"""
- self.sourcePrefix = sourcePrefix
self.targetPrefix = targetPrefix
def doProlog( self ):
@@ -54,10 +52,10 @@ class MakefileMaker:
filenames = filenames.split()
fullFilenames = []
for filename in filenames:
- if filename[0] != "/":
- fullFilenames.append( ( "%s%s" % ( self.sourcePrefix, filename ), "%s%s" % ( self.targetPrefix, filename ) ) )
+ if filename[0] != "$":
+ fullFilenames.append( "%s%s" % ( self.targetPrefix, filename ) )
else:
- fullFilenames.append( ( filename, filename ) )
+ fullFilenames.append( filename )
self.packages[name] = revision, description, dependencies, fullFilenames
def doBody( self ):
@@ -101,7 +99,7 @@ class MakefileMaker:
#
self.out( 'DESCRIPTION_%s="%s"' % ( name, desc ) )
self.out( 'PR_%s="ml%d"' % ( name, rev + BASEREV ) )
- self.out( 'RDEPENDS_%s="%s"' % ( name, deps.replace( ",", "" ) ) )
+ self.out( 'RDEPENDS_%s="%s"' % ( name, deps ) )
line = 'FILES_%s="' % name
@@ -110,14 +108,14 @@ class MakefileMaker:
#
dirset = {} # if python had a set-datatype this would be sufficient. for now, we're using a dict instead.
- for source, target in files:
+ for target in files:
dirset[os.path.dirname( target )] = True
#
# generate which files to copy for the target (-dfR because whole directories are also allowed)
#
- for source, target in files:
+ for target in files:
line += "%s " % target
line += '"'
@@ -147,33 +145,29 @@ if __name__ == "__main__":
# Parameters: revision, name, description, dependencies, filenames
#
- m.setPrefix( "/", "/usr/" )
-
m.addPackage( 2, "python-core", "Python Interpreter and core modules (needed!)", "",
- "lib/python2.5/__future__.* lib/python2.5/copy.* lib/python2.5/copy_reg.* lib/python2.5/ConfigParser.* " +
- "lib/python2.5/getopt.* lib/python2.5/linecache.* lib/python2.5/new.* " +
- "lib/python2.5/os.* lib/python2.5/posixpath.* " +
- "lib/python2.5/warnings.* lib/python2.5/site.* lib/python2.5/stat.* " +
- "lib/python2.5/UserDict.* lib/python2.5/UserList.* lib/python2.5/UserString.* " +
- "lib/python2.5/lib-dynload/binascii.so lib/python2.5/lib-dynload/struct.so lib/python2.5/lib-dynload/time.so " +
- "lib/python2.5/lib-dynload/xreadlines.so lib/python2.5/types.* bin/python*" )
+ "__future__.* copy.* copy_reg.* ConfigParser.* " +
+ "getopt.* linecache.* new.* " +
+ "os.* posixpath.* struct.* " +
+ "warnings.* site.* stat.* " +
+ "UserDict.* UserList.* UserString.* " +
+ "lib-dynload/binascii.so lib-dynload/_struct.so lib-dynload/time.so " +
+ "lib-dynload/xreadlines.so types.* ${bindir}/python*" )
m.addPackage( 0, "python-core-dbg", "Python core module debug information", "python-core",
- "lib/python2.5/lib-dynload/.debug bin/.debug lib/.debug" )
+ "lib-dynload/.debug ${bindir}/.debug ${libdir}/.debug" )
m.addPackage( 0, "python-devel", "Python Development Package", "python-core",
- "include lib/python2.5/config" ) # package
+ "${includedir} config" ) # package
- m.addPackage( 0, "python-idle", "Python Integrated Development Environment", "python-core, python-tkinter",
- "bin/idle lib/python2.5/idlelib" ) # package
+ m.addPackage( 0, "python-idle", "Python Integrated Development Environment", "python-core python-tkinter",
+ "${bindir}/idle idlelib" ) # package
- m.addPackage( 0, "python-pydoc", "Python Interactive Help Support", "python-core, python-lang, python-stringold, python-re",
- "bin/pydoc lib/python2.5/pydoc.*" )
+ m.addPackage( 0, "python-pydoc", "Python Interactive Help Support", "python-core python-lang python-stringold python-re",
+ "${bindir}/pydoc pydoc.*" )
m.addPackage( 0, "python-smtpd", "Python Simple Mail Transport Daemon", "python-core python-netserver python-email python-mime",
- "bin/smtpd.*" )
-
- m.setPrefix( "/lib/python2.5/", "${libdir}/python2.5/" )
+ "${bindir}/smtpd.*" )
m.addPackage( 0, "python-audio", "Python Audio Handling", "python-core",
"wave.* chunk.* sndhdr.* lib-dynload/ossaudiodev.so lib-dynload/audioop.so" )
@@ -190,31 +184,31 @@ if __name__ == "__main__":
m.addPackage( 0, "python-compiler", "Python Compiler Support", "python-core",
"compiler" ) # package
- m.addPackage( 0, "python-compression", "Python High Level Compression Support", "python-core, python-zlib",
+ m.addPackage( 0, "python-compression", "Python High Level Compression Support", "python-core python-zlib",
"gzip.* zipfile.*" )
m.addPackage( 0, "python-crypt", "Python Basic Cryptographic and Hashing Support", "python-core",
- "lib-dynload/crypt.so lib-dynload/md5.so lib-dynload/rotor.so lib-dynload/sha.so" )
+ "hashlib.* md5.* sha.* lib-dynload/crypt.so lib-dynload/_hashlib.so lib-dynload/_sha256.so lib-dynload/_sha512.so" )
- m.addPackage( 0, "python-textutils", "Python Option Parsing, Text Wrapping and Comma-Separated-Value Support", "python-core, python-io, python-re, python-stringold",
+ m.addPackage( 0, "python-textutils", "Python Option Parsing, Text Wrapping and Comma-Separated-Value Support", "python-core python-io python-re python-stringold",
"lib-dynload/_csv.so csv.* optparse.* textwrap.*" )
m.addPackage( 0, "python-curses", "Python Curses Support", "python-core",
"curses lib-dynload/_curses.so lib-dynload/_curses_panel.so" ) # package
- m.addPackage( 0, "python-datetime", "Python Calendar and Time support", "python-core, python-codecs",
+ m.addPackage( 0, "python-datetime", "Python Calendar and Time support", "python-core python-codecs",
"_strptime.* calendar.* lib-dynload/datetime.so" )
m.addPackage( 0, "python-db", "Python File-Based Database Support", "python-core",
"anydbm.* dumbdbm.* whichdb.* " )
- m.addPackage( 0, "python-debugger", "Python Debugger", "python-core, python-io, python-lang, python-re, python-stringold, python-shell",
+ m.addPackage( 0, "python-debugger", "Python Debugger", "python-core python-io python-lang python-re python-stringold python-shell",
"bdb.* pdb.*" )
m.addPackage( 0, "python-distutils", "Python Distribution Utilities", "python-core",
"config distutils" ) # package
- m.addPackage( 0, "python-email", "Python Email Support", "python-core, python-io, python-re, python-mime, python-audio python-image",
+ m.addPackage( 0, "python-email", "Python Email Support", "python-core python-io python-re python-mime python-audio python-image",
"email" ) # package
m.addPackage( 0, "python-fcntl", "Python's fcntl Interface", "python-core",
@@ -232,7 +226,7 @@ if __name__ == "__main__":
m.addPackage( 0, "python-image", "Python Graphical Image Handling", "python-core",
"colorsys.* imghdr.* lib-dynload/imageop.so lib-dynload/rgbimg.so" )
- m.addPackage( 0, "python-io", "Python Low-Level I/O", "python-core, python-math",
+ m.addPackage( 0, "python-io", "Python Low-Level I/O", "python-core python-math",
"lib-dynload/_socket.so lib-dynload/_ssl.so lib-dynload/select.so lib-dynload/termios.so lib-dynload/cStringIO.so "
"pipes.* socket.* tempfile.* StringIO.* " )
@@ -242,7 +236,7 @@ if __name__ == "__main__":
"atexit.* bisect.* code.* codeop.* dis.* heapq.* inspect.* keyword.* opcode.* repr.* token.* tokenize.* " +
"traceback.* linecache.* weakref.*" )
- m.addPackage( 0, "python-logging", "Python Logging Support", "python-core",
+ m.addPackage( 0, "python-logging", "Python Logging Support", "python-core python-io python-lang python-stringold",
"logging" ) # package
m.addPackage( 0, "python-lib-old-and-deprecated", "Python Deprecated Libraries", "python-core",
@@ -254,23 +248,23 @@ if __name__ == "__main__":
m.addPackage( 0, "python-math", "Python Math Support", "python-core",
"lib-dynload/cmath.so lib-dynload/math.so lib-dynload/_random.so random.* sets.*" )
- m.addPackage( 0, "python-mime", "Python MIME Handling APIs", "python-core, python-io",
+ m.addPackage( 0, "python-mime", "Python MIME Handling APIs", "python-core python-io",
"mimetools.* uu.* quopri.* rfc822.*" )
- m.addPackage( 0, "python-mmap", "Python Memory-Mapped-File Support", "python-core, python-io",
+ m.addPackage( 0, "python-mmap", "Python Memory-Mapped-File Support", "python-core python-io",
"lib-dynload/mmap.so " )
m.addPackage( 0, "python-unixadmin", "Python Unix Administration Support", "python-core",
"lib-dynload/nis.so lib-dynload/grp.so lib-dynload/pwd.so getpass.*" )
- m.addPackage( 0, "python-netclient", "Python Internet Protocol Clients", "python-core, python-datetime, python-io, python-lang, python-logging, python-mime",
+ m.addPackage( 0, "python-netclient", "Python Internet Protocol Clients", "python-core python-datetime python-io python-lang python-logging python-mime",
"*Cookie*.* " +
"base64.* cookielib.* ftplib.* gopherlib.* hmac.* httplib.* mimetypes.* nntplib.* poplib.* smtplib.* telnetlib.* urllib.* urllib2.* urlparse.*" )
- m.addPackage( 0, "python-netserver", "Python Internet Protocol Servers", "python-core, python-netclient",
+ m.addPackage( 0, "python-netserver", "Python Internet Protocol Servers", "python-core python-netclient",
"cgi.* BaseHTTPServer.* SimpleHTTPServer.* SocketServer.*" )
- m.addPackage( 0, "python-pickle", "Python Persistence Support", "python-core, python-codecs, python-io, python-re",
+ m.addPackage( 0, "python-pickle", "Python Persistence Support", "python-core python-codecs python-io python-re",
"pickle.* shelve.* lib-dynload/cPickle.so" )
m.addPackage( 0, "python-pprint", "Python Pretty-Print Support", "python-core",
@@ -288,46 +282,46 @@ if __name__ == "__main__":
m.addPackage( 0, "python-resource", "Python Resource Control Interface", "python-core",
"lib-dynload/resource.so" )
- m.addPackage( 0, "python-shell", "Python Shell-Like Functionality", "python-core, python-re",
+ m.addPackage( 0, "python-shell", "Python Shell-Like Functionality", "python-core python-re",
"cmd.* commands.* dircache.* fnmatch.* glob.* popen2.* shutil.*" )
- m.addPackage( 0, "python-robotparser", "Python robots.txt parser", "python-core, python-netclient",
+ m.addPackage( 0, "python-robotparser", "Python robots.txt parser", "python-core python-netclient",
"robotparser.*")
- m.addPackage( 0, "python-subprocess", "Python Subprocess Support", "python-core, python-io, python-re, python-fcntl, python-pickle",
+ m.addPackage( 0, "python-subprocess", "Python Subprocess Support", "python-core python-io python-re python-fcntl python-pickle",
"subprocess.*" )
m.addPackage( 0, "python-sqlite3", "Python Sqlite3 Database Support", "python-core",
"sqlite3" ) # package
- m.addPackage( 0, "python-stringold", "Python String APIs [deprecated]", "python-core, python-re",
+ m.addPackage( 0, "python-stringold", "Python String APIs [deprecated]", "python-core python-re",
"lib-dynload/strop.so string.*" )
m.addPackage( 0, "python-syslog", "Python's syslog Interface", "python-core",
"lib-dynload/syslog.so" )
- m.addPackage( 0, "python-terminal", "Python Terminal Controlling Support", "python-core, python-io",
+ m.addPackage( 0, "python-terminal", "Python Terminal Controlling Support", "python-core python-io",
"pty.* tty.*" )
m.addPackage( 0, "python-tests", "Python Tests", "python-core",
"test" ) # package
- m.addPackage( 0, "python-threading", "Python Threading & Synchronization Support", "python-core, python-lang",
+ m.addPackage( 0, "python-threading", "Python Threading & Synchronization Support", "python-core python-lang",
"_threading_local.* dummy_thread.* dummy_threading.* mutex.* threading.* Queue.*" )
- m.addPackage( 0, "python-unittest", "Python Unit Testing Framework", "python-core, python-stringold, python-lang",
+ m.addPackage( 0, "python-unittest", "Python Unit Testing Framework", "python-core python-stringold python-lang",
"unittest.*" )
- m.addPackage( 0, "python-xml", "Python basic XML support.", "python-core, python-re",
+ m.addPackage( 0, "python-xml", "Python basic XML support.", "python-core python-re python-netclient",
"lib-dynload/pyexpat.so xml xmllib.*" ) # package
- m.addPackage( 0, "python-xmlrpc", "Python XMLRPC Support", "python-core, python-xml, python-netserver, python-lang",
+ m.addPackage( 0, "python-xmlrpc", "Python XMLRPC Support", "python-core python-xml python-netserver python-lang",
"xmlrpclib.* SimpleXMLRPCServer.*" )
m.addPackage( 0, "python-zlib", "Python zlib Support.", "python-core",
"lib-dynload/zlib.so" )
- m.addPackage( 0, "python-mailbox", "Python Mailbox Format Support", "python-core, python-mime",
+ m.addPackage( 0, "python-mailbox", "Python Mailbox Format Support", "python-core python-mime",
"mailbox.*" )
m.make()