aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-12-05 17:06:14 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-12-05 17:06:14 +0000
commit20f081f50569670fdc7088d711ed2bd34b2bb11b (patch)
treeac0247b980c05786e1fb8cadb5e7e59794318c8a /contrib/python
parent85ad8d701fd3606dabd76c7cce2c74f080d0d984 (diff)
downloadopenembedded-20f081f50569670fdc7088d711ed2bd34b2bb11b.tar.gz
python 2.5.1 enable and package ctypes module/package. closes #3368 -- thanks emdete!
Diffstat (limited to 'contrib/python')
-rwxr-xr-xcontrib/python/generate-manifest-2.5.py12
1 files changed, 8 insertions, 4 deletions
diff --git a/contrib/python/generate-manifest-2.5.py b/contrib/python/generate-manifest-2.5.py
index 1317f23b4a..d4b7ea16f6 100755
--- a/contrib/python/generate-manifest-2.5.py
+++ b/contrib/python/generate-manifest-2.5.py
@@ -2,7 +2,8 @@
# generate Python Manifest for the OpenEmbedded build system
# (C) 2002-2007 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
-# MIT license
+# (C) 2007 Jeremy Laine
+# licensed under MIT, see COPYING.MIT
import os
import sys
@@ -10,10 +11,10 @@ import time
VERSION = "2.5.1"
# increase when touching python-core, this should be the same ml version as in python_2.5.1.bb
-BASEREV = 2
+BASEREV = 3
__author__ = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-__version__ = "20070823"
+__version__ = "20071205"
class MakefileMaker:
@@ -194,7 +195,10 @@ if __name__ == "__main__":
"lib-dynload/_csv.so csv.* optparse.* textwrap.*" )
m.addPackage( 0, "python-curses", "Python Curses Support", "python-core",
- "curses lib-dynload/_curses.so lib-dynload/_curses_panel.so" ) # package
+ "curses lib-dynload/_curses.so lib-dynload/_curses_panel.so" ) # directory + low level module
+
+ m.addPackage( 0, "python-ctypes", "Python C Types Support", "python-core",
+ "ctypes lib-dynload/_ctypes.so" ) # directory + low level module
m.addPackage( 0, "python-datetime", "Python Calendar and Time support", "python-core python-codecs",
"_strptime.* calendar.* lib-dynload/datetime.so" )