aboutsummaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-18 13:56:59 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-18 13:57:47 +0100
commitbd415877ea420a848481f72a3227fdc577c5242c (patch)
tree57addbe6c9628125b1649b0ce4e5e531b3df63b6 /contrib
parent1d85542eb64ec28aae9b70694b4f8b7680b42c0d (diff)
downloadopenembedded-bd415877ea420a848481f72a3227fdc577c5242c.tar.gz
oe_audit.py: Parse the full output of bitbake -s
Instead of being forced to manually edit we can now parse the full output of bitbake -s.
Diffstat (limited to 'contrib')
-rwxr-xr-xcontrib/qa/oe_audit.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/contrib/qa/oe_audit.py b/contrib/qa/oe_audit.py
index 7e04480626..905f1108d3 100755
--- a/contrib/qa/oe_audit.py
+++ b/contrib/qa/oe_audit.py
@@ -11,6 +11,9 @@ def read_available(filename):
packages = {}
for line in f:
+ if line.startswith("NOTE: ") or line.startswith("Parsing .bb"):
+ continue
+
# str.split can not be used as we have multiple whitespace
first_space = line.find(" ")
package = line[0:first_space]