aboutsummaryrefslogtreecommitdiffstats
path: root/curl
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /curl
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'curl')
-rw-r--r--curl/curl-7.12.2/m4.patch53
-rw-r--r--curl/curl-7.12.2/pkgconfig.patch47
2 files changed, 100 insertions, 0 deletions
diff --git a/curl/curl-7.12.2/m4.patch b/curl/curl-7.12.2/m4.patch
index e69de29bb2..c9a9eec28d 100644
--- a/curl/curl-7.12.2/m4.patch
+++ b/curl/curl-7.12.2/m4.patch
@@ -0,0 +1,53 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- curl-7.12.0/acinclude.m4~m4 2004-05-07 20:29:02.000000000 +0200
++++ curl-7.12.0/acinclude.m4 2004-06-07 19:03:47.000000000 +0200
+@@ -409,45 +409,7 @@
+
+ dnl determine if this strerror_r() is glibc or POSIX
+ AC_MSG_CHECKING([for a glibc strerror_r API])
+- AC_TRY_RUN([
+-#include <string.h>
+-#include <errno.h>
+-int
+-main () {
+- char buffer[1024]; /* big enough to play with */
+- char *string =
+- strerror_r(EACCES, buffer, sizeof(buffer));
+- /* this should've returned a string */
+- if(!string || !string[0])
+- return 99;
+- return 0;
+-}
+-],
+- AC_DEFINE(HAVE_GLIBC_STRERROR_R, 1, [we have a glibc-style strerror_r()])
+- AC_MSG_RESULT([yes]),
+- AC_MSG_RESULT([no])
+- )
+-
+ AC_MSG_CHECKING([for a POSIX strerror_r API])
+- AC_TRY_RUN([
+-#include <string.h>
+-#include <errno.h>
+-int
+-main () {
+- char buffer[1024]; /* big enough to play with */
+- int error =
+- strerror_r(EACCES, buffer, sizeof(buffer));
+- /* This should've returned zero, and written an error string in the
+- buffer.*/
+- if(!buffer[0] || error)
+- return 99;
+- return 0;
+-}
+-],
+- AC_DEFINE(HAVE_POSIX_STRERROR_R, 1, [we have a POSIX-style strerror_r()])
+- AC_MSG_RESULT([yes]),
+- AC_MSG_RESULT([no])
+- )
+
+ fi
+
diff --git a/curl/curl-7.12.2/pkgconfig.patch b/curl/curl-7.12.2/pkgconfig.patch
index e69de29bb2..da62b4e44d 100644
--- a/curl/curl-7.12.2/pkgconfig.patch
+++ b/curl/curl-7.12.2/pkgconfig.patch
@@ -0,0 +1,47 @@
+--- tmp/work/curl-7.12.0-r0/curl-7.12.0/configure.ac 2004-05-25 16:43:39.000000000 -0500
++++ curl-7.12.0/configure.ac 2004-07-15 18:13:18.000000000 -0500
+@@ -1389,7 +1389,8 @@
+ packages/EPM/curl.list \
+ packages/EPM/Makefile \
+ packages/vms/Makefile \
+- curl-config
++ curl-config \
++ curl.pc
+ ])
+ AC_OUTPUT
+
+--- tmp/work/curl-7.12.0-r0/curl-7.12.0/Makefile.am 2004-05-17 16:41:02.000000000 -0500
++++ curl-7.12.0/Makefile.am 2004-07-15 18:10:32.000000000 -0500
+@@ -24,10 +24,16 @@
+ AUTOMAKE_OPTIONS = foreign
+
+ EXTRA_DIST = CHANGES COPYING maketgz reconf Makefile.dist \
+- curl-config.in curl-style.el sample.emacs testcurl.sh RELEASE-NOTES
++ curl-config.in curl-style.el sample.emacs testcurl.sh RELEASE-NOTES \
++ curl.pc.in
+
+ bin_SCRIPTS = curl-config
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = curl.pc
++
++$(pkgconfig_DATA): config.status
++
+ SUBDIRS = lib src
+ DIST_SUBDIRS = $(SUBDIRS) tests include packages docs
+
+--- tmp/work/curl-7.12.0-r0/curl-7.12.0/curl.pc.in 1969-12-31 18:00:00.000000000 -0600
++++ curl-7.12.0/curl.pc.in 2004-07-15 18:09:14.000000000 -0500
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++versionnum=@VERSIONNUM@
++features=@FEATURES@
++
++Name: curl
++Description: a library that groks URLs
++Version: @VERSION@
++Libs: -L${libdir} -lcurl @LDFLAGS@ @LIBS@
++Cflags: -I${includedir}