aboutsummaryrefslogtreecommitdiffstats
path: root/docs/usermanual/chapters/metadata.xml
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-29 09:32:17 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-29 09:32:17 +0200
commit9202275b2381a1b2f9e74862673b4a85d0a68c1c (patch)
treeb88a0fdf7205097be6f3cc4d8e4900e5aa41bd4e /docs/usermanual/chapters/metadata.xml
parent293b05335ab540c4c8402e0a5caf2886b786a318 (diff)
parent28bc48904e31c3a63cf5a60bc005ed8fb359cc52 (diff)
downloadopenembedded-9202275b2381a1b2f9e74862673b4a85d0a68c1c.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/testing2010
Diffstat (limited to 'docs/usermanual/chapters/metadata.xml')
-rw-r--r--docs/usermanual/chapters/metadata.xml18
1 files changed, 9 insertions, 9 deletions
diff --git a/docs/usermanual/chapters/metadata.xml b/docs/usermanual/chapters/metadata.xml
index bbf6f733bb..794c66ce15 100644
--- a/docs/usermanual/chapters/metadata.xml
+++ b/docs/usermanual/chapters/metadata.xml
@@ -95,7 +95,7 @@
<para>OpenEmbedded has files ending with <emphasis>.conf</emphasis>,
<emphasis>.inc</emphasis>, <emphasis>.bb</emphasis>
- and<emphasis>.bbclass</emphasis>. The syntax and semantics of these files
+ and <emphasis>.bbclass</emphasis>. The syntax and semantics of these files
are best described in the <ulink
url="http://bitbake.berlios.de/manual"><application>BitBake</application>
manual</ulink>.</para>
@@ -111,7 +111,7 @@
<section id="metadata_writing_data">
<title>Writing Meta Data (Adding packages)</title>
- <para>This page will guide you trough the effort of writing a .bb file or
+ <para>This page will guide you through the effort of writing a .bb file or
<emphasis>recipe</emphasis> in BitBake speak.</para>
<para>Let's start with the easy stuff, like the package description,
@@ -128,23 +128,23 @@ DEPENDS = "gtk+"
RDEPENDS = "cool-ttf-fonts"
</screen> The package needs gtk+ to build ('DEPENDS') and
requires the 'cool-ttf-fonts' package to run ('RDEPENDS'). OE will add
- run-time dependencies on libraries on its own via the so called
- <emphasis>shlibs</emphasis>-code, but you need to specify everything other
+ run-time dependencies on libraries on its own via the so called
+ <emphasis>shlibs</emphasis>-code, but you need to specify everything else
by yourself, which in this case is the 'cool-ttf-fonts' package.</para>
<para>After entering all this OE will know what to build before trying to
build your application, but it doesn't know where to get it yet. So let's
add the source location: <screen>
SRC_URI = "http://www.host.com/foo/files/${P}.tar.bz2;md5sum=yoursum"
- </screen> This will tell the fetcher to where to download the
+ </screen> This will tell the fetcher where to download the
sources from and it will check the integrity using md5sum if you provided
the appropriate <emphasis>yoursum</emphasis>. You can make one by doing
<screen>md5sum foo-1.9.tar.bz2</screen> and replacing
<emphasis>yoursum</emphasis> with the md5sum on your screen. A typical
- md5sum will look like this: <screen>a6434b0fc8a54c3dec3d6875bf3be8mtn </screen>Notice
- the <emphasis>${P}</emphasis> variable, that one holds the package name,
- <emphasis>${PN}</emphasis> in BitBake speak and the package version,
- <emphasis>${PV}</emphasis> in BitBake speak. It's a short way of writing
+ md5sum will look like this: <screen>a6434b0fc8a54c3dec3d6875bf3be868 </screen>Notice
+ the <emphasis>${P}</emphasis> variable holds the package name
+ (<emphasis>${PN}</emphasis> in BitBake speak) and the package version
+ (<emphasis>${PV}</emphasis> in BitBake speak). It's a short way of writing
<emphasis>${PN}-${PV}</emphasis>. Using this notation means you can copy
the recipe when a new version is released without having to alter the
contents. You do need to check if everything is still correct, because new