aboutsummaryrefslogtreecommitdiffstats
path: root/docs/usermanual/chapters
diff options
context:
space:
mode:
authorMichael Jones <michael.jones@matrix-vision.de>2010-05-18 05:35:35 +0000
committerCliff Brake <cbrake@bec-systems.com>2010-05-18 12:02:09 -0400
commit8bd97afd2357483726949a34086f9fd8a6bf6f2d (patch)
tree67cf17b1d5bbfdd44d2fd04a1f22dab6f29b24c1 /docs/usermanual/chapters
parente2a7e630d408fb884d33e7b363572f6b854f7a07 (diff)
downloadopenembedded-8bd97afd2357483726949a34086f9fd8a6bf6f2d.tar.gz
docs/ spelling fixes
Just a few things in the documentation I noticed while reading up on OE. I don't understand why 'git diff' included "\ No newline at end of file" for some of these, or how I could instruct it not to, but I also didn't want to pick apart my patch outside of git. Signed-off-by: Michael Jones <michael.jones@matrix-vision.de>
Diffstat (limited to 'docs/usermanual/chapters')
-rw-r--r--docs/usermanual/chapters/metadata.xml2
-rw-r--r--docs/usermanual/chapters/recipes.xml18
-rw-r--r--docs/usermanual/chapters/usage.xml10
3 files changed, 15 insertions, 15 deletions
diff --git a/docs/usermanual/chapters/metadata.xml b/docs/usermanual/chapters/metadata.xml
index c698be961a..bbf6f733bb 100644
--- a/docs/usermanual/chapters/metadata.xml
+++ b/docs/usermanual/chapters/metadata.xml
@@ -95,7 +95,7 @@
<para>OpenEmbedded has files ending with <emphasis>.conf</emphasis>,
<emphasis>.inc</emphasis>, <emphasis>.bb</emphasis>
- and<emphasis>.bbclass</emphasis>. The syntax and semantic of these files
+ and<emphasis>.bbclass</emphasis>. The syntax and semantics of these files
are best described in the <ulink
url="http://bitbake.berlios.de/manual"><application>BitBake</application>
manual</ulink>.</para>
diff --git a/docs/usermanual/chapters/recipes.xml b/docs/usermanual/chapters/recipes.xml
index 9a0349f7c0..6a574d87b7 100644
--- a/docs/usermanual/chapters/recipes.xml
+++ b/docs/usermanual/chapters/recipes.xml
@@ -451,7 +451,7 @@ mv fixed.recipe.bb myrecipe.bb</screen></para>
</listitem>
<listitem>
- <para>The classes, that are used via the inherit keyword, define
+ <para>The classes that are used via the inherit keyword define
and/or use the majority of the remaining variables. A class is like
a library that contains parts of a bitbake recipe that is used by
multiple recipes. To make them usable in more situations they often
@@ -503,7 +503,7 @@ mv fixed.recipe.bb myrecipe.bb</screen></para>
<para>Practically all recipes start with a header section which describes
various aspects of the package that is being built. This information is
typically used directly by the package format (such as ipkg or deb) as
- it's meta data used to describe the package.</para>
+ its meta data used to describe the package.</para>
<para>Variables used in the header include:</para>
@@ -835,7 +835,7 @@ S = "${WORKDIR}/widgets"</screen></para>
<title>D: The destination directory</title>
<para>The destination directory is where the completed application and
- all of it's files are installed into in preparation for packaging.
+ all of its files are installed into in preparation for packaging.
Typically an installation would place files in directories such as
<emphasis role="bold">/etc</emphasis> and <emphasis
role="bold">/usr/bin</emphasis> by default. Since those directories are
@@ -1037,7 +1037,7 @@ ${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/files:${FILE_DIRNAME}"</screen></para>
done is when one recipe includes another one in which the default values
will be based on the name of the package doing the including, not the
included package. Typically the included package will expect the files
- to be located in a directory based on it's own name.</para>
+ to be located in a directory based on its own name.</para>
<para>As an example the m4-native recipe includes the m4 recipe. This is
fine, except that the m4 recipe expects its files and patches to be
@@ -1458,7 +1458,7 @@ inherit autotools</screen></para>
</section>
<section id="recipes_methods" xreflabel="methods">
- <title>Methods: Inbuilt methods to make your life easier</title>
+ <title>Methods: Built-in methods to make your life easier</title>
<para>There are several helper functions defined by the base class, which
is included by default for all recipes. Many of these are used a lot in
@@ -1931,7 +1931,7 @@ NOTE: package helloworld-0.1-r0: task do_package_write: completed</screen>We
<listitem>
<para>Documentation related files. All documentation is
- separated into it's own package so that it does not need to be
+ separated into its own package so that it does not need to be
installed unless explicitly required.<screen>FILES_${PN}-doc = "\
${docdir} \
${mandir} \
@@ -2447,7 +2447,7 @@ addtask unpack_extra after do_unpack before do_patch</screen></para>
building later applications.</para>
<para>Taking bzip2 as an example you can see that it stages a header file
- and it's library files:<screen>do_stage () {
+ and its library files:<screen>do_stage () {
install -m 0644 bzlib.h ${STAGING_INCDIR}/
oe_libinstall -a -so libbz2 ${STAGING_LIBDIR}
}</screen></para>
@@ -2929,7 +2929,7 @@ fi</screen></para>
some action, such as changing user or group owners or creating device
nodes. Since OpenEmbedded will not keep the user and group information
it's usually preferable to remove that from the makefiles. For device
- nodes it's usually preferably to create them from the initial device node
+ nodes it's usually preferable to create them from the initial device node
lists or via udev configuration.</para>
<para>However if you can't get by without root permissions then you can
@@ -3135,7 +3135,7 @@ do_configure() {
object, then replaces any dots with underscores. Therefore if the <emphasis
role="bold">PV</emphasis> was <emphasis role="bold">0.9.0</emphasis> then
<emphasis role="bold">TAG</emphasis> will be set to <emphasis
- role="bold">0-9-0</emphasis>.</para>
+ role="bold">0_9_0</emphasis>.</para>
<para>Some of the more common python code in use in existing recipes is
shown in the following table:</para>
diff --git a/docs/usermanual/chapters/usage.xml b/docs/usermanual/chapters/usage.xml
index 9f2b7160c7..1563dc3eac 100644
--- a/docs/usermanual/chapters/usage.xml
+++ b/docs/usermanual/chapters/usage.xml
@@ -5,7 +5,7 @@
<section id="usage_introduction" xreflabel="introduction">
<title>Introduction</title>
- <para>If your reading this manual you probably already have some idea of
+ <para>If you're reading this manual you probably already have some idea of
what OpenEmbedded is all about, which is taking a lot of software and
creating something that you can run on another device. This involves
downloading some source code, compiling it, creating packages (like .deb
@@ -13,7 +13,7 @@
device. The difficulties of cross-compiling and the variety of devices
which can be supported lead to a lot more complexity in an OpenEmbedded
based distribution than you'd find in a typical desktop distribution
- (which cross-compiling isn't needed).</para>
+ (for which cross-compiling isn't needed).</para>
<para>A major part of OpenEmbedded deals with compiling source code for
various projects. For each project this generally requires the same basic
@@ -745,7 +745,7 @@ NOTE: build 200705041709: completed</screen><note>
available for other applications to include and link against.</para>
<note>
- <para>This is different to the <emphasis>install</emphasis> task
+ <para>This is different from the <emphasis>install</emphasis> task
in that this is responsible for making available libraries and
headers for use during build on the development host. Therefore
it's libraries which normal have to stage things while
@@ -853,7 +853,7 @@ NOTE: package perl-5.8.8-r11: task do_listtasks: completed
NOTE: package perl-5.8.8: completed
$ </screen></para>
- <para>If your being observant you'll note that
+ <para>If you're being observant you'll note that
<emphasis>listtasks</emphasis> is in fact a task itself, and that the
<emphasis role="bold">-c</emphasis> option to bitbake allows you to
explicitly run specific tasks. We'll make use of this in the next section
@@ -876,7 +876,7 @@ $ </screen></para>
the named recipe only. Note that this ignores any dependencies that are in
the recipe, so these must have already been built previously.</para>
- <para>Here's a typically example that cleans up the package (using the
+ <para>Here's a typical example that cleans up the package (using the
<emphasis>clean</emphasis> task) and the rebuilds it with debugging output
from bitbake enabled:<screen>$ <command>bitbake</command> -b &lt;bb-file&gt; -c clean
$ <command>bitbake</command> -b &lt;bb-file&gt; -D</screen></para>