aboutsummaryrefslogtreecommitdiffstats
path: root/glibc
diff options
context:
space:
mode:
authorHolger Schurig <schurig@mn-solutions.de>2004-10-01 09:27:59 +0000
committerHolger Schurig <schurig@mn-solutions.de>2004-10-01 09:27:59 +0000
commit3831c69357bfde04dd0e3e7213a1e6c91215a607 (patch)
tree0c7ae39918243f7bdf70df3e8b1a5266cc66b364 /glibc
parent6c40059939365b8790359c5b9c643244d734eedf (diff)
downloadopenembedded-3831c69357bfde04dd0e3e7213a1e6c91215a607.tar.gz
The problem was with patch dyn-ldconfig.diff, which broke patches applied
in 10_cvs.patch and ldconfig.patch by not adding _dl_cache_libcmp to the exports in GLIBC_PRIVATE{} inside glibc-2.3.3/elf/Verisons. BKrev: 415d231fH_U6J-W408PrxDEclpn8uA
Diffstat (limited to 'glibc')
-rw-r--r--glibc/glibc-2.3.2/dyn-ldconfig.diff62
-rw-r--r--glibc/glibc_2.3.2.oe13
2 files changed, 64 insertions, 11 deletions
diff --git a/glibc/glibc-2.3.2/dyn-ldconfig.diff b/glibc/glibc-2.3.2/dyn-ldconfig.diff
index e69de29bb2..471cf63040 100644
--- a/glibc/glibc-2.3.2/dyn-ldconfig.diff
+++ b/glibc/glibc-2.3.2/dyn-ldconfig.diff
@@ -0,0 +1,62 @@
+--- elf/Makefile 13 Mar 2003 21:50:57 -0000 1.258
++++ elf/Makefile 27 Mar 2003 20:36:07 -0000
+@@ -109,12 +109,13 @@
+
+ ifeq (yes,$(use-ldconfig))
+ ifeq (yes,$(build-shared))
+-others-static += ldconfig
++#others-static += ldconfig
+ others += ldconfig
+ install-rootsbin += ldconfig
+
+ ldconfig-modules := cache readlib xmalloc xstrdup chroot_canon
+ extra-objs += $(ldconfig-modules:=.o)
++CPPFLAGS-readlib.c = -DNOT_IN_libc=1
+
+ # To find xmalloc.c and xstrdup.c
+ vpath %.c ../locale/programs
+--- elf/ldconfig.c 13 Jan 2003 08:53:14 -0000 1.31
++++ elf/ldconfig.c 27 Mar 2003 20:36:09 -0000
+@@ -149,6 +149,9 @@
+ static int
+ is_hwcap_platform (const char *name)
+ {
++#if 1
++ return 0;
++#else
+ int hwcap_idx = _dl_string_hwcap (name);
+
+ if (hwcap_idx != -1 && ((1 << hwcap_idx) & hwcap_mask))
+@@ -164,6 +167,7 @@
+ #endif
+
+ return 0;
++#endif
+ }
+
+ /* Get hwcap (including platform) encoding of path. */
+@@ -175,6 +179,7 @@
+ uint64_t hwcap = 0;
+ uint64_t h;
+
++#if 0
+ size_t len;
+
+ len = strlen (str);
+@@ -210,6 +215,7 @@
+ *ptr = '\0';
+ }
+
++#endif
+ free (str);
+ return hwcap;
+ }
+--- elf/Versions.old Fri Oct 1 06:32:06 2004
++++ elf/Versions Fri Oct 1 06:44:13 2004
+@@ -54,5 +54,6 @@
+ _rtld_global; _dl_tls_symaddr; _dl_allocate_tls; _dl_deallocate_tls;
+ _dl_get_tls_static_info; _dl_allocate_tls_init;
+ _dl_get_origin; _dl_tls_setup; _dl_rtld_di_serinfo;
++ _dl_cache_libcmp;
+ }
+ }
diff --git a/glibc/glibc_2.3.2.oe b/glibc/glibc_2.3.2.oe
index 2051bf732e..468b4423a1 100644
--- a/glibc/glibc_2.3.2.oe
+++ b/glibc/glibc_2.3.2.oe
@@ -1,8 +1,9 @@
-PR = "r3"
DESCRIPTION = "GNU C Library"
+HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
LICENSE = "LGPL"
SECTION = "libs"
PRIORITY = "required"
+PR = "r4"
GLIBC_ADDONS ?= "linuxthreads"
GLIBC_EXTRA_OECONF ?= ""
@@ -47,16 +48,6 @@ FILES_glibc-pcprofile = "/lib/libpcprofile.so"
FILES_glibc-thread-db = "/lib/libthread_db*"
FILES_localedef = "${bindir}/localedef"
-# file://noinfo.patch;patch=1 \
-# file://ldconfig.patch;patch=1;pnum=0 \
-
-# file://dyn-ldconfig.diff;patch=1;pnum=0
-# file://glibcbug.patch;patch=1;pnum=0
-# file://nptl-pthread-once.patch;patch=1;pnum=1
-# file://50_glibc232-hppa-full-nptl-2003-10-22.patch;patch=1;pnum=1
-# file://alpha-crti.patch;patch=1;pnum=1
-# file://glibc-make-check-perms.patch;patch=1;pnum=0
-# This patch is needed for builds against recent 2.5/2.6 kernel headers:
SRC_URI = "ftp://ftp.gnu.org/gnu/glibc/glibc-${PV}.tar.gz \
ftp://ftp.gnu.org/pub/gnu/glibc/glibc-linuxthreads-2.3.2.tar.gz \
file://noinfo.patch;patch=1 \