aboutsummaryrefslogtreecommitdiffstats
path: root/mozilla
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2004-07-30 16:09:04 +0000
committerPhil Blundell <philb@gnu.org>2004-07-30 16:09:04 +0000
commit1fc829c54867469b948e1ffbbeca30adf0060f4a (patch)
tree6d6892663f581bfb7b6f42614ad3f20d70565d03 /mozilla
parentebee9c423854ab1609a10ecabba583890d916e41 (diff)
downloadopenembedded-1fc829c54867469b948e1ffbbeca30adf0060f4a.tar.gz
Merge bk://openembedded@openembedded.bkbits.net/packages
into stealth.(none):/home/pb/oe/oe-packages 2004/07/30 01:18:57+01:00 (none)!pb Merge bk://openembedded@openembedded.bkbits.net/packages into stealth.(none):/home/pb/oe/oe-packages 2004/07/30 01:18:48+01:00 (none)!pb firefox_0.9.oe: Rename: BitKeeper/deleted/.del-firefox_0.9.oe~8a7a21a26bf8e182 -> mozilla/firefox_0.9.oe firefox_0.9.2.oe: Rename: BitKeeper/deleted/.del-firefox_0.9.2.oe~e84ef1b02667e7af -> mozilla/firefox_0.9.2.oe .del-firefox_0.9.oe~8a7a21a26bf8e182: Delete: mozilla/firefox_0.9.oe .del-firefox_0.9.2.oe~e84ef1b02667e7af: Delete: mozilla/firefox_0.9.2.oe BKrev: 410a72a0jp9g3ISgjz88ACxxd0udqQ
Diffstat (limited to 'mozilla')
-rw-r--r--mozilla/firefox_0.9.2.oe2
-rw-r--r--mozilla/firefox_0.9.oe40
2 files changed, 41 insertions, 1 deletions
diff --git a/mozilla/firefox_0.9.2.oe b/mozilla/firefox_0.9.2.oe
index 831befd574..dd44bf99ec 100644
--- a/mozilla/firefox_0.9.2.oe
+++ b/mozilla/firefox_0.9.2.oe
@@ -14,7 +14,7 @@ FILES_${PN} += "${libdir}/firefox-${PV} ${datadir}/idl"
CFLAGS := "${@'${CFLAGS}'.replace('-frename-registers', '')} -fsigned-char -fno-strict-aliasing"
CXXFLAGS := "${@'${CXXFLAGS}'.replace('-frename-registers', '')} -fsigned-char -fno-strict-aliasing"
-SELECTED_OPTIMIZATION = "-Os"
+#SELECTED_OPTIMIZATION = "-Os"
export CROSS_COMPILE=1
export HOST_LIBIDL_CONFIG="libIDL-config-2"
diff --git a/mozilla/firefox_0.9.oe b/mozilla/firefox_0.9.oe
index e69de29bb2..d6ea89a4a5 100644
--- a/mozilla/firefox_0.9.oe
+++ b/mozilla/firefox_0.9.oe
@@ -0,0 +1,40 @@
+DEPENDS = "xt xi zip-native gtk+ orbit2"
+PR = "r3"
+
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/firefox-${PV}-source.tar.bz2 \
+ file://mozconfig \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1"
+
+S = "${WORKDIR}/mozilla"
+
+FILES_${PN} += "${libdir}/firefox-${PV} ${datadir}/idl"
+
+# gcc-3.4 blows up in gtktext with -frename-registers on arm-linux
+CFLAGS := "${@'${CFLAGS}'.replace('-frename-registers', '')} -fsigned-char -fno-strict-aliasing"
+CXXFLAGS := "${@'${CXXFLAGS}'.replace('-frename-registers', '')} -fsigned-char -fno-strict-aliasing"
+
+SELECTED_OPTIMIZATION = "-Os"
+
+export CROSS_COMPILE=1
+export HOST_LIBIDL_CONFIG="libIDL-config-2"
+export CONFIGURE_ARGS="--target=${TARGET_SYS} --host=${BUILD_SYS} --build=${BUILD_SYS} --prefix=${prefix}"
+
+export HOST_CFLAGS="${BUILD_CFLAGS}"
+export HOST_CXXFLAGS="${BULID_CXXFLAGS}"
+export HOST_LDFLAGS="${BUILD_LDFLAGS}"
+export HOST_RANLIB="${BUILD_RANLIB}"
+export HOST_AR="${BUILD_AR}"
+
+do_configure() {
+ cp ${WORKDIR}/mozconfig .mozconfig
+}
+
+do_compile() {
+ make -f client.mk build_all
+}
+
+do_install() {
+ make DESTDIR="${D}" install
+}
+