aboutsummaryrefslogtreecommitdiffstats
path: root/packages/alp
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-07-12 16:27:19 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-07-12 16:27:19 +0000
commit6273ca92d5f24fdf7e8c940e58998e66a86598ae (patch)
treedd319d84094dfdf2f98882920305bbd61a576186 /packages/alp
parentf1bfc57bc6f847b6848c90e995070c8a2832b708 (diff)
downloadopenembedded-6273ca92d5f24fdf7e8c940e58998e66a86598ae.tar.gz
hiker: Add 0.9.1... we silently ignore demos installed to wron directories.
Diffstat (limited to 'packages/alp')
-rw-r--r--packages/alp/hiker_0.9.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/alp/hiker_0.9.1.bb b/packages/alp/hiker_0.9.1.bb
new file mode 100644
index 0000000000..2c6c1d7647
--- /dev/null
+++ b/packages/alp/hiker_0.9.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Hiker Application Framework™"
+LICENSE = "MPL"
+
+DEPENDS = "gtk+ sqlite3 gnet dbus-glib openssl"
+
+SRC_URI = "http://www.access-company.com/downloads/${P}.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+export CFLAGS += "-DALP_BUILD=ALP_BUILD_DEBUG"
+export CXXFLAGS += "-DALP_BUILD=ALP_BUILD_DEBUG"
+
+do_configure_prepend() {
+ sed -i s:unittest::g utils/Makefile.am
+}
+
+PACKAGES =+ "libhiker libsqlfs"
+FILES_libhiker += "${libdir}/libhiker*.so.*"
+FILES_libsqlfs += "${libdir}/libsql*.so.*"
+
+do_stage() {
+ autotools_stage_all
+}
+