aboutsummaryrefslogtreecommitdiffstats
path: root/packages/alp
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-22 19:19:32 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-22 19:19:32 +0000
commit7849cfd166f605c0abd1175d3a5f9f488485c941 (patch)
tree5970fe9b9b35294ba67b63d14ad0175ca25907d4 /packages/alp
parent7c872b1394a47c8049e241e20e41c93911192be6 (diff)
downloadopenembedded-7849cfd166f605c0abd1175d3a5f9f488485c941.tar.gz
hiker: initial version of Access' hiker application framework
Diffstat (limited to 'packages/alp')
-rw-r--r--packages/alp/.mtn2git_empty0
-rw-r--r--packages/alp/hiker_0.9.bb24
2 files changed, 24 insertions, 0 deletions
diff --git a/packages/alp/.mtn2git_empty b/packages/alp/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/alp/.mtn2git_empty
diff --git a/packages/alp/hiker_0.9.bb b/packages/alp/hiker_0.9.bb
new file mode 100644
index 0000000000..17e34efceb
--- /dev/null
+++ b/packages/alp/hiker_0.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Hiker Application Framework™"
+LICENSE = "MPL"
+
+DEPENDS = "gtk+ sqlite3 gnet dbus-glib"
+
+SRC_URI = "http://www.access-company.com/downloads/${P}.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+export CFLAGS += "-DALP_BUILD=ALP_BUILD_DEBUG"
+export CXXFLAGS += "-DALP_BUILD=ALP_BUILD_DEBUG"
+
+do_configure_prepend() {
+ sed -i s:unittest::g utils/Makefile.am
+}
+
+PACKAGES =+ "libhiker libsqlfs"
+FILES_libhiker += "${libdir}/libhiker*.so.*"
+FILES_libsqlfs += "${libdir}/libsql*.so.*"
+
+do_stage() {
+ autotools_stage_all
+}
+