aboutsummaryrefslogtreecommitdiffstats
path: root/packages/alsa
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-06 19:45:15 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-06 19:45:36 +0100
commitd696906d5fe25469ec9be2247e7dba5df052e534 (patch)
tree750144de5534de7f6655c9dfda3b7baeebf00607 /packages/alsa
parent329a808d87724ade13f72ef502dad3c6a7ad7b4f (diff)
downloadopenembedded-d696906d5fe25469ec9be2247e7dba5df052e534.tar.gz
alsa-state: add state files for MOTO a780
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/alsa-state.bb9
-rw-r--r--packages/alsa/alsa-state/a780/asound.state80
-rw-r--r--packages/alsa/alsa-state/a780/gsmhandset.state55
-rw-r--r--packages/alsa/alsa-state/a780/gsmheadset.state55
-rw-r--r--packages/alsa/alsa-state/a780/stereoout.state55
5 files changed, 170 insertions, 84 deletions
diff --git a/packages/alsa/alsa-state.bb b/packages/alsa/alsa-state.bb
index 58c724f79c..ba030e4aab 100644
--- a/packages/alsa/alsa-state.bb
+++ b/packages/alsa/alsa-state.bb
@@ -4,15 +4,16 @@
#
# Filename: alsa-state.bb
-DESCRIPTION = "Default ALSA configuration"
-LICENSE = "GPL"
-PV = "0.1.0"
-PR = "r18"
+DESCRIPTION = "Alsa Scenario Files"
+LICENSE = "MIT"
+PV = "0.2.0"
+PR = "r0"
SRC_URI = "\
file://asound.conf \
file://asound.state \
file://alsa-state \
+ file://*.state \
"
inherit update-rc.d
diff --git a/packages/alsa/alsa-state/a780/asound.state b/packages/alsa/alsa-state/a780/asound.state
deleted file mode 100644
index eafd409857..0000000000
--- a/packages/alsa/alsa-state/a780/asound.state
+++ /dev/null
@@ -1,80 +0,0 @@
-state.EZX {
- control.1 {
- comment.access 'read write'
- comment.type INTEGER
- comment.count 1
- comment.range '0 - 15'
- iface MIXER
- name 'Output gain'
- value 9
- }
- control.2 {
- comment.access 'read write'
- comment.type INTEGER
- comment.count 1
- comment.range '0 - 31'
- iface MIXER
- name 'Input gain'
- value 14
- }
- control.3 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Input Mixer A3 Switch'
- value true
- }
- control.4 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Input Mixer A5 Switch'
- value true
- }
- control.5 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer A1 Switch'
- value true
- }
- control.6 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer A2 Switch'
- value true
- }
- control.7 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer AR Switch'
- value true
- }
- control.8 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer AL Switch'
- value true
- }
- control.9 {
- comment.access 'read write'
- comment.type ENUMERATED
- comment.count 1
- comment.item.0 '2ch'
- comment.item.1 '2->1ch'
- comment.item.2 '2->1ch -3db'
- comment.item.3 '2->1ch -6db'
- iface MIXER
- name Downmixer
- value '2ch'
- }
-}
diff --git a/packages/alsa/alsa-state/a780/gsmhandset.state b/packages/alsa/alsa-state/a780/gsmhandset.state
new file mode 100644
index 0000000000..c9adfb3340
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/gsmhandset.state
@@ -0,0 +1,55 @@
+state.EZX {
+ control.1 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Master Playback Volume'
+ value 6
+ }
+ control.2 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Stereo
+ comment.item.1 Mono
+ comment.item.2 BP
+ iface MIXER
+ name 'DAI Select'
+ value BP
+ }
+ control.3 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 31'
+ iface MIXER
+ name 'Capture Volume'
+ value 14
+ }
+ control.4 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 '2->1ch'
+ comment.item.2 '2->1ch -3db'
+ comment.item.3 '2->1ch -6db'
+ iface MIXER
+ name Downmixer
+ value Off
+ }
+ control.5 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 Loudspeaker
+ comment.item.2 Earpiece
+ comment.item.3 Headset
+ iface MIXER
+ name 'Output mode'
+ value Earpiece
+ }
+}
diff --git a/packages/alsa/alsa-state/a780/gsmheadset.state b/packages/alsa/alsa-state/a780/gsmheadset.state
new file mode 100644
index 0000000000..7b72789410
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/gsmheadset.state
@@ -0,0 +1,55 @@
+state.EZX {
+ control.1 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Master Playback Volume'
+ value 6
+ }
+ control.2 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Stereo
+ comment.item.1 Mono
+ comment.item.2 BP
+ iface MIXER
+ name 'DAI Select'
+ value BP
+ }
+ control.3 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 31'
+ iface MIXER
+ name 'Capture Volume'
+ value 14
+ }
+ control.4 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 '2->1ch'
+ comment.item.2 '2->1ch -3db'
+ comment.item.3 '2->1ch -6db'
+ iface MIXER
+ name Downmixer
+ value Off
+ }
+ control.5 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 Loudspeaker
+ comment.item.2 Earpiece
+ comment.item.3 Headset
+ iface MIXER
+ name 'Output mode'
+ value Headset
+ }
+}
diff --git a/packages/alsa/alsa-state/a780/stereoout.state b/packages/alsa/alsa-state/a780/stereoout.state
new file mode 100644
index 0000000000..64b36a0572
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/stereoout.state
@@ -0,0 +1,55 @@
+state.EZX {
+ control.1 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Master Playback Volume'
+ value 6
+ }
+ control.2 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Stereo
+ comment.item.1 Mono
+ comment.item.2 BP
+ iface MIXER
+ name 'DAI Select'
+ value Stereo
+ }
+ control.3 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 31'
+ iface MIXER
+ name 'Capture Volume'
+ value 14
+ }
+ control.4 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 '2->1ch'
+ comment.item.2 '2->1ch -3db'
+ comment.item.3 '2->1ch -6db'
+ iface MIXER
+ name Downmixer
+ value Off
+ }
+ control.5 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 Loudspeaker
+ comment.item.2 Earpiece
+ comment.item.3 Headset
+ iface MIXER
+ name 'Output mode'
+ value Loudspeaker
+ }
+}