aboutsummaryrefslogtreecommitdiffstats
path: root/packages/altboot
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-03-01 18:14:21 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-01 18:14:21 +0000
commitca83ab4389e988210ab0691dfd4dc29f54e6dfb6 (patch)
tree875cb0dc4b847cadddda46e483c39d077619f37c /packages/altboot
parent46698c5ce7137787023e838a0f1fd9a0ff214b17 (diff)
downloadopenembedded-ca83ab4389e988210ab0691dfd4dc29f54e6dfb6.tar.gz
altboot: Last changes before the stable relase
Diffstat (limited to 'packages/altboot')
-rw-r--r--packages/altboot/altboot_0.0.0.bb2
-rw-r--r--packages/altboot/files/altboot-menu/Advanced/70-install-tgz4
-rw-r--r--packages/altboot/files/altboot.func2
-rw-r--r--packages/altboot/files/altboot.rc/loadkeymap.sh5
4 files changed, 8 insertions, 5 deletions
diff --git a/packages/altboot/altboot_0.0.0.bb b/packages/altboot/altboot_0.0.0.bb
index e52070c817..6aaa7ead05 100644
--- a/packages/altboot/altboot_0.0.0.bb
+++ b/packages/altboot/altboot_0.0.0.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
IGNORE_STRIP_ERRORS = "1"
-PR = "r24"
+PR = "r25"
SRC_URI = "file://altboot-menu \
diff --git a/packages/altboot/files/altboot-menu/Advanced/70-install-tgz b/packages/altboot/files/altboot-menu/Advanced/70-install-tgz
index 2ae44fa890..cdfa052747 100644
--- a/packages/altboot/files/altboot-menu/Advanced/70-install-tgz
+++ b/packages/altboot/files/altboot-menu/Advanced/70-install-tgz
@@ -141,7 +141,7 @@ install_rootfs_direct(){
sync
echo "done"
- umount "$1"
+# umount "$1"
echo "Press <ENTER> to bring up the altboot menu"
read junk </dev/tty0 >/dev/tty0 2>&1
@@ -210,7 +210,7 @@ install_rootfs_image(){
if test -n "$junk"
then
- if test "$junk" -gt 30
+ if test "$junk" -gt 29
then
echo -n "Is [${junk}Mb] correct? [Y|n] "
read junk2
diff --git a/packages/altboot/files/altboot.func b/packages/altboot/files/altboot.func
index d7737ece96..c6af50a008 100644
--- a/packages/altboot/files/altboot.func
+++ b/packages/altboot/files/altboot.func
@@ -312,7 +312,7 @@ init_rootfs(){
}
mount_sd(){
- if mount | grep -q "/media/card "
+ if mount | grep -q "/media/card"
then
echo "Note: /media/card is already mounted"
else
diff --git a/packages/altboot/files/altboot.rc/loadkeymap.sh b/packages/altboot/files/altboot.rc/loadkeymap.sh
index f9a7774549..97cff13dbb 100644
--- a/packages/altboot/files/altboot.rc/loadkeymap.sh
+++ b/packages/altboot/files/altboot.rc/loadkeymap.sh
@@ -1,5 +1,8 @@
#!/bin/sh
# Note: With kernel 2.6 the standard keymap is unusable
-test -x /etc/init.d/keymap && /etc/init.d/keymap start >/dev/null 2>&1
+test -x /etc/init.d/keymap && /etc/init.d/keymap start >/dev/null 2>&1
+
+# Do not exit w/ errorcode when the if above fails
+/bin/true