aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apache
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
committerHolger Freyther <zecke@selfish.org>2006-11-18 16:55:13 +0000
commit56b7d78a034187f66e08f3b3e2de55bd878cf9b5 (patch)
treed6f4033c0064f41c2205502d10c651e8710c96aa /packages/apache
parent9e61974759ef6e4ff9538a33bab0e82b1b4381dd (diff)
downloadopenembedded-56b7d78a034187f66e08f3b3e2de55bd878cf9b5.tar.gz
Micro-Optimisation decreasing initial parsing time by 10%
python () {} and python __anonymous () {} are as the same says functions without a name. They get executed when the main bb file is completely parsed. This is used to set information like FILESDIR. This is a python method so it gets evaled which means compiled and executed a lot of times. By moving the code of the anonfunc into a proper method this is only compiled once. The result is is the 10% speed up when parsing. Reindent anonfuncs and new defs without tabs and four spaces
Diffstat (limited to 'packages/apache')
-rw-r--r--packages/apache/apache_2.0.54.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/packages/apache/apache_2.0.54.bb b/packages/apache/apache_2.0.54.bb
index 7f714724db..ff0f23e010 100644
--- a/packages/apache/apache_2.0.54.bb
+++ b/packages/apache/apache_2.0.54.bb
@@ -82,10 +82,10 @@ do_install_append () {
}
python () {
- # Don't build apache unless we are building nativly
- target = bb.data.getVar("TARGET_ARCH", d, 1)
- build = bb.data.getVar("BUILD_ARCH", d, 1)
- if target != build:
- raise bb.parse.SkipPackage("Apache will only build nativly (TARGET_ARCH == BUILD_ARCH)")
+ # Don't build apache unless we are building nativly
+ target = bb.data.getVar("TARGET_ARCH", d, 1)
+ build = bb.data.getVar("BUILD_ARCH", d, 1)
+ if target != build:
+ raise bb.parse.SkipPackage("Apache will only build nativly (TARGET_ARCH == BUILD_ARCH)")
}