aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apr
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-02 17:57:05 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-02 17:57:05 +0100
commit856a5edd50db5e6383e881f4f4c622461a62af45 (patch)
treea3547654301fc4eed3d9447ded3d129a06329a7e /packages/apr
parent973e72926d884e2b7d0abb9ab45ee3924a4e30fe (diff)
downloadopenembedded-856a5edd50db5e6383e881f4f4c622461a62af45.tar.gz
apr: beat its autotools into the 21 first century
Diffstat (limited to 'packages/apr')
-rw-r--r--packages/apr/apr/configure_fixes.patch40
-rw-r--r--packages/apr/apr_1.2.12.bb5
2 files changed, 41 insertions, 4 deletions
diff --git a/packages/apr/apr/configure_fixes.patch b/packages/apr/apr/configure_fixes.patch
index 2b2e0eccb2..88e1e2163a 100644
--- a/packages/apr/apr/configure_fixes.patch
+++ b/packages/apr/apr/configure_fixes.patch
@@ -1,7 +1,5 @@
-Index: apr-1.2.12/configure.in
-===================================================================
---- apr-1.2.12.orig/configure.in 2008-03-08 21:41:43.000000000 +0000
-+++ apr-1.2.12/configure.in 2008-03-08 21:43:08.000000000 +0000
+--- /tmp/configure.in 2009-02-02 17:50:51.000000000 +0100
++++ apr-1.2.12/configure.in 2009-02-02 17:54:55.000000000 +0100
@@ -13,12 +13,11 @@
dnl
dnl Include our own M4 macros along with those for libtool
@@ -20,3 +18,37 @@ Index: apr-1.2.12/configure.in
dnl Hard-coded inclusion at the tail end of apr_private.h:
AH_BOTTOM([
+@@ -197,8 +196,8 @@
+
+ if test "x$use_libtool" = "xyes"; then
+ lt_compile='$(LIBTOOL) $(LTFLAGS) --mode=compile $(COMPILE) -o $@ -c $< && touch $@'
+- LT_VERSION="-version-info `$get_version libtool $version_hdr APR`"
+- link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LT_LDFLAGS) \$(COMPILE) ${LT_VERSION} \$(ALL_LDFLAGS) -o \$@"
++ LV_VERSION="-version-info `$get_version libtool $version_hdr APR`"
++ link="\$(LIBTOOL) \$(LTFLAGS) --mode=link \$(LV_LDFLAGS) \$(COMPILE) ${LV_VERSION} \$(ALL_LDFLAGS) -o \$@"
+ so_ext='lo'
+ lib_target='-rpath $(libdir) $(OBJECTS)'
+ export_lib_target='-rpath \$(libdir) \$(OBJECTS)'
+@@ -225,7 +224,7 @@
+ AC_SUBST(export_lib_target)
+ AC_SUBST(shlibpath_var)
+ AC_SUBST(LTFLAGS)
+-AC_SUBST(LT_LDFLAGS)
++AC_SUBST(LV_LDFLAGS)
+
+ dnl ----------------------------- Checks for compiler flags
+ nl='
+@@ -2132,10 +2131,10 @@
+ # against installed versions of libapr instead of those just
+ # built.
+ case $host in
+-*-apple-darwin*) LT_NO_INSTALL="" ;;
+-*) LT_NO_INSTALL="-no-install" ;;
++*-apple-darwin*) LV_NO_INSTALL="" ;;
++*) LV_NO_INSTALL="-no-install" ;;
+ esac
+-AC_SUBST(LT_NO_INSTALL)
++AC_SUBST(LV_NO_INSTALL)
+
+ #
+ # BSD/OS (BSDi) needs to use a different include syntax in the Makefiles
diff --git a/packages/apr/apr_1.2.12.bb b/packages/apr/apr_1.2.12.bb
index 923e9b380c..2ee0c32020 100644
--- a/packages/apr/apr_1.2.12.bb
+++ b/packages/apr/apr_1.2.12.bb
@@ -11,6 +11,11 @@ SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
inherit autotools lib_package binconfig
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
+
+do_configure_prepend() {
+ rm -f ${S}/build/libtool.m4
+}
do_stage() {
autotools_stage_all