aboutsummaryrefslogtreecommitdiffstats
path: root/packages/aspell/aspell_0.50.5.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/aspell/aspell_0.50.5.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/aspell/aspell_0.50.5.bb')
-rw-r--r--packages/aspell/aspell_0.50.5.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/aspell/aspell_0.50.5.bb b/packages/aspell/aspell_0.50.5.bb
index e69de29bb2..8b8c5e779b 100644
--- a/packages/aspell/aspell_0.50.5.bb
+++ b/packages/aspell/aspell_0.50.5.bb
@@ -0,0 +1,28 @@
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz \
+ file://mk-dirs_h.py \
+ file://makefile.patch;patch=1"
+DESCRIPTION = "GNU Aspell spell-checker"
+SECTION = "console/utils"
+LICENSE="LGPL"
+
+PACKAGES =+ "libaspell libpspell libpspell-dev aspell-utils"
+
+FILES_libaspell = "${libdir}/libaspell.so.* ${datadir}/aspell"
+FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell"
+FILES_${PN} = "${bindir}/aspell"
+FILES_libpspell = "${libdir}/libpspell.so.*"
+FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
+
+inherit autotools
+
+do_compile_prepend() {
+ install ${WORKDIR}/mk-dirs_h.py ${S}/common/mk-dirs_h
+}
+
+do_stage() {
+ oe_libinstall -C lib -so libaspell ${STAGING_LIBDIR}
+ install -m 0644 interfaces/cc/aspell.h ${STAGING_INCDIR}
+ oe_libinstall -C lib -so libpspell ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/pspell
+ install -m 0644 interfaces/cc/pspell.h ${STAGING_INCDIR}/pspell
+}