aboutsummaryrefslogtreecommitdiffstats
path: root/packages/aspell
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/aspell
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/aspell')
-rw-r--r--packages/aspell/.mtn2git_empty0
-rw-r--r--packages/aspell/aspell-0.50.5/.mtn2git_empty0
-rw-r--r--packages/aspell/aspell-0.50.5/makefile.patch20
-rwxr-xr-x[-rw-r--r--]packages/aspell/aspell-0.50.5/mk-dirs_h.py20
-rw-r--r--packages/aspell/aspell_0.50.5.bb28
5 files changed, 68 insertions, 0 deletions
diff --git a/packages/aspell/.mtn2git_empty b/packages/aspell/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/aspell/.mtn2git_empty
diff --git a/packages/aspell/aspell-0.50.5/.mtn2git_empty b/packages/aspell/aspell-0.50.5/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/aspell/aspell-0.50.5/.mtn2git_empty
diff --git a/packages/aspell/aspell-0.50.5/makefile.patch b/packages/aspell/aspell-0.50.5/makefile.patch
index e69de29bb2..c16a32e3b9 100644
--- a/packages/aspell/aspell-0.50.5/makefile.patch
+++ b/packages/aspell/aspell-0.50.5/makefile.patch
@@ -0,0 +1,20 @@
+--- aspell-0.50.5/common/Makefile.am~ 2002-11-05 00:24:14.000000000 +0000
++++ aspell-0.50.5/common/Makefile.am 2004-06-27 14:33:37.000000000 +0100
+@@ -4,7 +4,7 @@
+ pkgdatadir = @pkgdatadir@
+ pkglibdir = @pkglibdir@
+
+-noinst_PROGRAMS = mk-dirs_h
++#noinst_PROGRAMS = mk-dirs_h
+
+ dirs.h: mk-dirs_h
+ echo '#define PREFIX "${prefix}"' > dirs.h
+@@ -12,7 +12,7 @@
+ ./mk-dirs_h ${prefix} DATA_DIR ${pkgdatadir} >> dirs.h
+ ./mk-dirs_h ${prefix} CONF_DIR ${sysconfdir} >> dirs.h
+
+-mk_dirs_h_SOURCES = mk-dirs_h.cpp
++#mk_dirs_h_SOURCES = mk-dirs_h.cpp
+
+ config.cpp: dirs.h
+
diff --git a/packages/aspell/aspell-0.50.5/mk-dirs_h.py b/packages/aspell/aspell-0.50.5/mk-dirs_h.py
index e69de29bb2..a487751e81 100644..100755
--- a/packages/aspell/aspell-0.50.5/mk-dirs_h.py
+++ b/packages/aspell/aspell-0.50.5/mk-dirs_h.py
@@ -0,0 +1,20 @@
+#!/usr/bin/env python
+
+import sys
+
+prefix=sys.argv[1]
+key=sys.argv[2]
+value=sys.argv[3]
+
+while prefix[-1] == '/':
+ prefix = prefix[:-2]
+
+plen = len(prefix)
+
+if value[:plen] == prefix:
+ value = value[plen:]
+ while value[0] == '/':
+ value = value[1:]
+ print "#define " + key + " \"<prefix:" + value + ">\"\n"
+else:
+ print "#define " + key + " \"" + value + "\"\n"
diff --git a/packages/aspell/aspell_0.50.5.bb b/packages/aspell/aspell_0.50.5.bb
index e69de29bb2..8b8c5e779b 100644
--- a/packages/aspell/aspell_0.50.5.bb
+++ b/packages/aspell/aspell_0.50.5.bb
@@ -0,0 +1,28 @@
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz \
+ file://mk-dirs_h.py \
+ file://makefile.patch;patch=1"
+DESCRIPTION = "GNU Aspell spell-checker"
+SECTION = "console/utils"
+LICENSE="LGPL"
+
+PACKAGES =+ "libaspell libpspell libpspell-dev aspell-utils"
+
+FILES_libaspell = "${libdir}/libaspell.so.* ${datadir}/aspell"
+FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell"
+FILES_${PN} = "${bindir}/aspell"
+FILES_libpspell = "${libdir}/libpspell.so.*"
+FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
+
+inherit autotools
+
+do_compile_prepend() {
+ install ${WORKDIR}/mk-dirs_h.py ${S}/common/mk-dirs_h
+}
+
+do_stage() {
+ oe_libinstall -C lib -so libaspell ${STAGING_LIBDIR}
+ install -m 0644 interfaces/cc/aspell.h ${STAGING_INCDIR}
+ oe_libinstall -C lib -so libpspell ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/pspell
+ install -m 0644 interfaces/cc/pspell.h ${STAGING_INCDIR}/pspell
+}