aboutsummaryrefslogtreecommitdiffstats
path: root/packages/aspell
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-04-03 11:14:00 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-04-03 11:14:00 +0000
commitcf4d59a97856faf1e539ec3b48feb155d5cefb6f (patch)
treef0e8a74a7c00ab7f3353ada856ab4a01d87dc582 /packages/aspell
parente1952029899a1212b48eb42080808acff8869a0a (diff)
downloadopenembedded-cf4d59a97856faf1e539ec3b48feb155d5cefb6f.tar.gz
aspell-native_0.60.5.bb, aspell6-en_6.0-0.bb, aspell_0.60.5.bb : some
speeling cheecker (spelling checker) updates. Moved to latest version of aspell and dictionaries.
Diffstat (limited to 'packages/aspell')
-rw-r--r--packages/aspell/aspell-lang.inc15
-rw-r--r--packages/aspell/aspell-native_0.60.5.bb6
-rw-r--r--packages/aspell/aspell6-en_6.0-0.bb14
-rw-r--r--packages/aspell/aspell_0.60.5.bb18
4 files changed, 44 insertions, 9 deletions
diff --git a/packages/aspell/aspell-lang.inc b/packages/aspell/aspell-lang.inc
index 709183b428..8c58136f0e 100644
--- a/packages/aspell/aspell-lang.inc
+++ b/packages/aspell/aspell-lang.inc
@@ -1,23 +1,20 @@
-FILES_${PN} = "/usr/lib/aspell/* /usr/share/aspell/*"
+FILES_${PN} = "/usr/lib/aspell* /usr/share/aspell*"
DEPENDS = "aspell-native"
do_configure() {
cd ${S}
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
- DESTDIR=${D} ./configure
+ DESTDIR=${D} ./configure --vars ASPELL=${STAGING_BINDIR_NATIVE}/aspell
}
do_compile() {
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
- dictdir=/usr/lib/aspell oe_runmake
+ sed -i -e "s|dictdir.*lib|dictdir = ${libdir}|" Makefile
+ sed -i -e "s|datadir.*lib|datadir = ${libdir}|" Makefile
+ oe_runmake
}
do_install() {
- export dictdir=/usr/lib/aspell/
- export datadir=/usr/share/aspell/
+ unset datadir
oe_runmake install
}
diff --git a/packages/aspell/aspell-native_0.60.5.bb b/packages/aspell/aspell-native_0.60.5.bb
new file mode 100644
index 0000000000..174821ce46
--- /dev/null
+++ b/packages/aspell/aspell-native_0.60.5.bb
@@ -0,0 +1,6 @@
+require aspell_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/aspell-${PV}"
+
diff --git a/packages/aspell/aspell6-en_6.0-0.bb b/packages/aspell/aspell6-en_6.0-0.bb
new file mode 100644
index 0000000000..6c013eb546
--- /dev/null
+++ b/packages/aspell/aspell6-en_6.0-0.bb
@@ -0,0 +1,14 @@
+LICENSE = "Copyright file"
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/dict/en/aspell6-en-${PV}.tar.bz2"
+PR="r1"
+
+require aspell-lang.inc
+
+FILES_${PN} += "${docdir}/Copyright"
+FILES_${PN}-doc = ""
+
+do_install_append() {
+ install -d ${D}${docdir}
+ install ${S}/Copyright ${D}${docdir}
+}
+
diff --git a/packages/aspell/aspell_0.60.5.bb b/packages/aspell/aspell_0.60.5.bb
new file mode 100644
index 0000000000..6b6c867226
--- /dev/null
+++ b/packages/aspell/aspell_0.60.5.bb
@@ -0,0 +1,18 @@
+SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz"
+DESCRIPTION = "GNU Aspell spell-checker"
+SECTION = "console/utils"
+LICENSE="LGPL"
+
+PACKAGES =+ "libaspell libpspell libpspell-dev aspell-utils"
+
+FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
+FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
+FILES_${PN} = "${bindir}/aspell"
+FILES_libpspell = "${libdir}/libpspell.so.*"
+FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}