aboutsummaryrefslogtreecommitdiffstats
path: root/packages/at76c503a
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/at76c503a
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/at76c503a')
-rw-r--r--packages/at76c503a/at76c503a-modules_cvs.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/at76c503a/at76c503a-modules_cvs.bb b/packages/at76c503a/at76c503a-modules_cvs.bb
index e69de29bb2..025a20ee1d 100644
--- a/packages/at76c503a/at76c503a-modules_cvs.bb
+++ b/packages/at76c503a/at76c503a-modules_cvs.bb
@@ -0,0 +1,35 @@
+SECTION = "base"
+LICENSE = "GPL"
+SRC_URI = "cvs://anonymous@cvs.berlios.de/cvsroot/at76c503a;module=at76c503a \
+ file://ipaq.patch;patch=1;pnum=0"
+S = "${WORKDIR}/at76c503a"
+PR = "r1"
+PV = "0.0cvs${CVSDATE}"
+
+inherit module
+
+MODULES = at76c503.o at76_usbdfu.o at76c503-i3861.o at76c503-rfmd.o at76c503-rfmd-acc.o \
+ at76c505-rfmd.o at76c503-i3863.o at76c505-rfmd2958.o
+
+pkg_postinst() {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+update-modules || true
+}
+
+pkg_postrm() {
+#!/bin/sh
+update-modules || true
+}
+
+do_install() {
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+ for i in ${MODULES}; do install -m 0644 $i ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/$i; done
+
+ if [ "${MACHINE}" = "h3900" ]; then
+ install -d ${D}/${sysconfdir}/modutils
+ echo "at76c503-rfmd" > ${D}/${sysconfdir}/modutils/at76c503-rfmd
+ fi
+}