aboutsummaryrefslogtreecommitdiffstats
path: root/packages/avr-libc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/avr-libc
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/avr-libc')
-rw-r--r--packages/avr-libc/.mtn2git_empty0
-rw-r--r--packages/avr-libc/avr-libc-1.0.3/.mtn2git_empty0
-rw-r--r--packages/avr-libc/avr-libc-1.0.3/configure.patch57
-rw-r--r--packages/avr-libc/avr-libc_1.0.3.bb37
4 files changed, 94 insertions, 0 deletions
diff --git a/packages/avr-libc/.mtn2git_empty b/packages/avr-libc/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/avr-libc/.mtn2git_empty
diff --git a/packages/avr-libc/avr-libc-1.0.3/.mtn2git_empty b/packages/avr-libc/avr-libc-1.0.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/avr-libc/avr-libc-1.0.3/.mtn2git_empty
diff --git a/packages/avr-libc/avr-libc-1.0.3/configure.patch b/packages/avr-libc/avr-libc-1.0.3/configure.patch
index e69de29bb2..3bfc8394c4 100644
--- a/packages/avr-libc/avr-libc-1.0.3/configure.patch
+++ b/packages/avr-libc/avr-libc-1.0.3/configure.patch
@@ -0,0 +1,57 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- avr-libc-1.0/./configure.in~configure
++++ avr-libc-1.0/./configure.in
+@@ -26,8 +26,9 @@
+ # ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ # POSSIBILITY OF SUCH DAMAGE.
+
+-AC_PREREQ(2.13)
+-AC_INIT(libc)
++AC_PREREQ(2.57)
++AC_INIT
++AC_CONFIG_SRCDIR([libc])
+
+ dnl Default to --enable-multilib
+ AC_ARG_ENABLE(multilib,
+@@ -132,7 +133,7 @@
+ AC_SUBST(avrlib_basedir)
+
+ # Determine the host, build, and target systems
+-AC_CANONICAL_SYSTEM
++AC_CANONICAL_TARGET([])
+
+ dnl NOTE: Don't put a '-' in the version number or rpm will puke
+ dnl when building the package.
+@@ -357,17 +358,16 @@
+ fi
+
+ dnl the top Makefile must be the last of the list
+-AC_OUTPUT(crt1/Makefile libc/Makefile libc/stdlib/Makefile
++AC_CONFIG_FILES([crt1/Makefile libc/Makefile libc/stdlib/Makefile
+ libc/pmstring/Makefile libc/string/Makefile libc/misc/Makefile
+ libc/stdio/Makefile
+ libm/Makefile libm/fplib/Makefile avr-libc.spec
+ doc/Makefile doc/examples/Makefile
+ doc/api/Makefile doc/api/doxygen.config
+- Makefile,
+-[if test -n "$CONFIG_FILES"; then
++ Makefile])
++AC_CONFIG_COMMANDS([default],[[if test -n "$CONFIG_FILES"; then
+ . ${avrlib_basedir}/config-ml.in
+-fi],
+-srcdir=${srcdir}
++fi]],[[srcdir=${srcdir}
+ host=${host}
+ target=${target}
+ with_multisubdir=${with_multisubdir}
+@@ -375,4 +375,5 @@
+ CONFIG_SHELL=${CONFIG_SHELL-/bin/sh}
+ avrlib_basedir=${avrlib_basedir}
+ CC="${CC}"
+-)
++]])
++AC_OUTPUT
diff --git a/packages/avr-libc/avr-libc_1.0.3.bb b/packages/avr-libc/avr-libc_1.0.3.bb
index e69de29bb2..1c627a1576 100644
--- a/packages/avr-libc/avr-libc_1.0.3.bb
+++ b/packages/avr-libc/avr-libc_1.0.3.bb
@@ -0,0 +1,37 @@
+HOMEPAGE = "http://www.nongnu.org/avr-libc"
+DESCRIPTION = "C library for use with GCC on Atmel AVR microcontrollers"
+PROVIDES = "virtual/libc"
+SECTION = "libs"
+LICENSE = "BSD"
+
+python __anonymous () {
+ import bb, re
+ if (re.match('avr', bb.data.getVar('TARGET_ARCH', d, 1)) == None):
+ raise bb.parse.SkipPackage("incompatible with arch %s" %
+ bb.data.getVar('TARGET_ARCH', d, 1))
+}
+
+SRC_URI = "http://savannah.nongnu.org/download/avr-libc/avr-libc-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+B = "${WORKDIR}/build.${BUILD_SYS}.${TARGET_SYS}"
+
+inherit autotools
+
+export tooldir = "${prefix}"
+prefix = "${CROSS_DIR}"
+exec_prefix = "${prefix}"
+
+do_stage () {
+# install into CROSS_DIR
+ oe_runmake install
+# install into STAGING_DIR
+ oe_runmake "prefix=${STAGING_DIR}" "exec_prefix=${STAGING_DIR}" \
+ "bindir=${STAGING_BINDIR}" "libdir=${STAGING_LIBDIR}" \
+ "tooldir=${STAGING_DIR}" "toolibdir=${STAGING_LIBDIR}" \
+ install
+}
+
+do_install () {
+# install into D
+ oe_runmake "DESTDIR=${D}" "tooldir=/" install
+}