aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bash
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-03-09 11:39:50 +0000
committerChris Larson <clarson@kergoth.com>2005-03-09 11:39:50 +0000
commit9415dc0f95c62f4421acb7a8f172dcaace941dea (patch)
tree53eeffed5b292c281db7ee8c10276a7f941f29e4 /packages/bash
parent50c64638f7510fa8d33867007bca515f3d8dd6fa (diff)
downloadopenembedded-9415dc0f95c62f4421acb7a8f172dcaace941dea.tar.gz
Fix the bash build for uclibc and kill the dangerous /bin/sh alternatives bits.
BKrev: 422ee086sm4RBQy79-EAyaUdInS9NA
Diffstat (limited to 'packages/bash')
-rw-r--r--packages/bash/bash_3.0.bb21
1 files changed, 2 insertions, 19 deletions
diff --git a/packages/bash/bash_3.0.bb b/packages/bash/bash_3.0.bb
index b7b40cfdc6..924898884c 100644
--- a/packages/bash/bash_3.0.bb
+++ b/packages/bash/bash_3.0.bb
@@ -3,8 +3,7 @@ HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
DEPENDS = "ncurses"
SECTION = "base/shell"
LICENSE = "GPL"
-PROVIDES = "virtual/sh"
-PR = "r3"
+PR = "r4"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
file://signames-mipsel.diff;patch=1"
@@ -18,22 +17,6 @@ EXTRA_OECONF = "--with-ncurses"
export CC_FOR_BUILD = "${BUILD_CC}"
do_configure () {
+ gnu-configize
oe_runconf
}
-
-# dont use update-alternatives class because since we are dealing with /bin/sh
-# we need to do the remove in pkg_prerm where the /bin/sh link still points
-# to something (postrm is a shell script)
-
-ALTERNATIVE_NAME = "sh"
-ALTERNATIVE_PATH = "${bindir}/bash"
-ALTERNATIVE_PRIORITY = "30"
-ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
-
-pkg_postinst() {
-update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
-}
-
-pkg_prerm() {
-update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
-}