aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bash
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-09-30 20:07:18 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-30 20:07:18 +0000
commitb18db4fdac6da2040f56a3fb6d7887f3ca93c8fa (patch)
tree174b9448a57f992e1f28dff5877aabe2cae522fd /packages/bash
parentce4ee8dedf7ab650d187fed8ece80803ca54c381 (diff)
downloadopenembedded-b18db4fdac6da2040f56a3fb6d7887f3ca93c8fa.tar.gz
bash: create sysconfdir/shells upon install
Diffstat (limited to 'packages/bash')
-rw-r--r--packages/bash/bash_3.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/bash/bash_3.0.bb b/packages/bash/bash_3.0.bb
index 2278e6ff31..cffe165bee 100644
--- a/packages/bash/bash_3.0.bb
+++ b/packages/bash/bash_3.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
DEPENDS = "ncurses"
SECTION = "base/shell"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
file://signames-mipsel.diff;patch=1"
@@ -22,3 +22,8 @@ do_configure () {
gnu-configize
oe_runconf
}
+
+pkg_postinst () {
+ grep "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
+ grep "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
+}