aboutsummaryrefslogtreecommitdiffstats
path: root/packages/beep
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-30 00:00:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-30 00:00:59 +0000
commit2682ab100d67b2199826a0e9318ab7657098cb45 (patch)
treed6052f277d151f94043e574085227532bd90b0cc /packages/beep
parent4e42240722712f1c0a15833ca3251a32876f7f83 (diff)
downloadopenembedded-2682ab100d67b2199826a0e9318ab7657098cb45.tar.gz
beep: release 1.2.2
Diffstat (limited to 'packages/beep')
-rw-r--r--packages/beep/beep_1.2.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/beep/beep_1.2.2.bb b/packages/beep/beep_1.2.2.bb
new file mode 100644
index 0000000000..1c28b17d87
--- /dev/null
+++ b/packages/beep/beep_1.2.2.bb
@@ -0,0 +1,31 @@
+# beep: a console utility to "and allow a little more granularity
+# than you get with the default terminal bell"
+DESCRIPTION = "A console utility to make a beep noise"
+SECTION = "console/utils"
+LICENSE = "GPL"
+MAINTAINER = "John Bowler <jbowler@nslu2-linux.org>"
+PR = "r1"
+DEPENDS = "install-native"
+
+SRC_URI = "http://johnath.com/beep/beep-${PV}.tar.gz"
+SRC_URI += "file://linux-input.patch;patch=1"
+
+S = "${WORKDIR}/beep-${PV}"
+PACKAGES = "${PN} ${PN}-doc"
+
+inherit autotools
+
+EXTRA_OEMAKE += 'CC="${CC}"'
+EXTRA_OEMAKE += 'FLAGS="${CFLAGS}"'
+
+# slugos requires beep in boot
+BINDIR = "${bindir}
+BINDIR_slugos = "${base_bindir}"
+
+do_install() {
+ # this is easier than patching the Makefile...
+ install -d "${D}${bindir}"
+ install -c -s -m 755 beep "${D}${BINDIR}/beep"
+ install -d "${D}${mandir}/man1"
+ install -c -m 644 beep.1.gz "${D}${mandir}/man1/beep.1.gz"
+}