aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bind/bind_9.3.4-P1.bb
diff options
context:
space:
mode:
authorEsben Haabendal <eha@doredevelopment.dk>2007-10-11 15:27:15 +0000
committerKoen Kooi <koen@openembedded.org>2007-10-11 15:27:15 +0000
commit6f39696a826f6a3512f1f61bb7b99800cc779263 (patch)
tree17d76b7ff6d5bfa6a978d5c6021592d502c9d93f /packages/bind/bind_9.3.4-P1.bb
parent87df1648a9629d9a7de92276f7813b65739de643 (diff)
downloadopenembedded-6f39696a826f6a3512f1f61bb7b99800cc779263.tar.gz
bind: update to 9.3.4
Diffstat (limited to 'packages/bind/bind_9.3.4-P1.bb')
-rw-r--r--packages/bind/bind_9.3.4-P1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/bind/bind_9.3.4-P1.bb b/packages/bind/bind_9.3.4-P1.bb
new file mode 100644
index 0000000000..59d2599a13
--- /dev/null
+++ b/packages/bind/bind_9.3.4-P1.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "ISC Internet Domain Name Server"
+SECTION = "console/network"
+HOMEPAGE = "http://www.isc.org/sw/bind/"
+LICENSE = "BSD"
+PR = "r0"
+
+DEPENDS = "openssl"
+
+SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.4-P1/bind-9.3.4-P1.tar.gz \
+ file://conf.patch;patch=1 \
+ file://configure.in.patch;patch=1 \
+ file://so_bsdcompat.patch;patch=1 \
+ "
+
+EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "bind"
+INITSCRIPT_PARAMS = "defaults"
+
+do_install_append() {
+ rm "${D}/usr/bin/nslookup"
+ install -d "${D}/etc/bind"
+ install -d "${D}/etc/init.d"
+ install -m 644 ${S}/conf/* "${D}/etc/bind"
+ install -m 755 "${S}/init.d" "${D}/etc/init.d/bind"
+}
+
+CONFFILES_${PN} = " \
+ ${sysconfdir}/bind/named.conf \
+ ${sysconfdir}/bind/named.conf.local \
+ ${sysconfdir}/bind/named.conf.options \
+ ${sysconfdir}/bind/db.0 \
+ ${sysconfdir}/bind/db.127 \
+ ${sysconfdir}/bind/db.empty \
+ ${sysconfdir}/bind/db.local \
+ ${sysconfdir}/bind/db.root \
+ "