aboutsummaryrefslogtreecommitdiffstats
path: root/packages/binutils/binutils.inc
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-07 16:56:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-07 16:56:38 +0000
commitc9138fb90537550373f8873469af0ab74c32c965 (patch)
tree4e5cb6b35219760be4770763350c45a94a9a352f /packages/binutils/binutils.inc
parent2341028888795de208d7a4ade232e74ff8fdac83 (diff)
downloadopenembedded-c9138fb90537550373f8873469af0ab74c32c965.tar.gz
binutils: patch 2.16 for uclibc, enable 2.16 on uclibc builds
2.16 now includes the patches which ensure that HOST_CC_ARCH is passed to the build, other than that this commit should only affect binutils for linux-uclibc targets. The patches which enable recognition of linux-uclibc*' as well as 'linux-gnu*' have integrated - in fact there are more places now where the change is made, which may improve some things. The apparently spurious 'autoreconf' of certain subdirectories in the build tree has been commented out (it did nothing because there is no configure.in or .am in the build directory).
Diffstat (limited to 'packages/binutils/binutils.inc')
-rw-r--r--packages/binutils/binutils.inc6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/binutils/binutils.inc b/packages/binutils/binutils.inc
index e544e9ef53..680e579a06 100644
--- a/packages/binutils/binutils.inc
+++ b/packages/binutils/binutils.inc
@@ -48,14 +48,14 @@ export LD_FOR_TARGET = "${TARGET_PREFIX}ld"
export NM_FOR_TARGET = "${TARGET_PREFIX}nm"
export RANLIB_FOR_TARGET = "${TARGET_PREFIX}ranlib"
-export CC_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc"
-export CXX_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc"
+export CC_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
+export CXX_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
export CC_FOR_BUILD = "${BUILD_CC}"
export CPP_FOR_BUILD = "${BUILD_CPP}"
export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-export CC = "${CCACHE} ${HOST_PREFIX}gcc"
+export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
do_configure () {
(cd ${S}; gnu-configize) || die "Failed to run gnu-configize"