aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bison
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-05-25 17:14:37 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-05-25 17:14:37 +0000
commitab67512dd0019cd2d0f1beb718de0fe255037509 (patch)
tree35cffb92c34aef7e3436c94955bfa21b7e702e78 /packages/bison
parentb59f7b5c9da751e5ef22f523565239cd75d76f74 (diff)
downloadopenembedded-ab67512dd0019cd2d0f1beb718de0fe255037509.tar.gz
Merge with OE (there may still be a bug in the busybox postinst script)
2005/05/25 16:24:12+01:00 reciva.com!pb patch usb.rc to work with busybox (no "grep -o") 2005/05/25 13:09:04+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/05/25 13:05:58+01:00 reciva.com!pb apply patch to udhcpc to send the current hostname if no -H option is given 2005/05/25 12:54:31+02:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/05/25 12:54:19+02:00 uni-frankfurt.de!mickeyl fix yacc in bison-native 2005/05/25 11:48:52+01:00 reciva.com!pb turn on support for "readlink -f", needed by usbutils 2005/05/25 11:40:50+01:00 reciva.com!pb Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/05/25 11:37:22+01:00 reciva.com!pb don't require /etc/httpd.conf to start busybox httpd, it works fine without that file 2005/05/25 12:29:58+02:00 handhelds.org!CoreDump Add altboot: A text based 'boot manager' (/sbin/init hack) to allow booting from SD and CF, boot a recovery shell (init=/bin/sh) or boot into a GUI-less runlevel 2005/05/25 11:24:50+01:00 reciva.com!pb package busybox udhcpd bits separately; remove stray copy of main postinst in -httpd package. 2005/05/25 11:52:12+02:00 local!hrw Merge bk://oe-devel.bkbits.net/openembedded into marcinj.local:/home/hrw/zaurus/oe/openembedded 2005/05/25 11:51:20+02:00 local!hrw regenerated dejavu fonts 2005/05/25 10:50:32+01:00 reciva.com!pb set default update-rc.d parameters to "defaults" BKrev: 4294b27d6MVA-cFYArKaJud80nBnzA
Diffstat (limited to 'packages/bison')
-rw-r--r--packages/bison/bison-native_2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/bison/bison-native_2.0.bb b/packages/bison/bison-native_2.0.bb
index e69de29bb2..624ece4b50 100644
--- a/packages/bison/bison-native_2.0.bb
+++ b/packages/bison/bison-native_2.0.bb
@@ -0,0 +1,19 @@
+include bison_${PV}.bb
+SECTION = "devel"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/bison-${PV}"
+S = "${WORKDIR}/bison-${PV}"
+PR = "r1"
+
+inherit native autotools
+
+do_stage() {
+ install -m 0755 src/bison ${STAGING_BINDIR}/
+ cat >${STAGING_BINDIR}/yacc <<EOF
+#!/bin/sh
+exec ${STAGING_BINDIR}/bison -y "\$@"
+EOF
+ chmod a+rx ${STAGING_BINDIR}/yacc
+ install -d ${STAGING_BINDIR}/../share/bison/m4sugar
+ install -m 0755 data/c.m4 data/glr.c data/lalr1.cc data/yacc.c ${STAGING_BINDIR}/../share/bison/
+ install -m 0755 data/m4sugar/m4sugar.m4 ${STAGING_BINDIR}/../share/bison/m4sugar/
+}