summaryrefslogtreecommitdiffstats
path: root/packages/boost
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2008-10-18 14:28:23 +0200
committerJeremy Lainé <jeremy.laine@m4x.org>2008-10-18 14:28:23 +0200
commit58774ccd9fd50634d01536d81afe24b2571dfa7e (patch)
tree467fafb7303d7d0253989cdf00d6f8589b12d628 /packages/boost
parent0592d2c50f7b37411869bfad4d67e42f0186c3db (diff)
downloadopenembedded-58774ccd9fd50634d01536d81afe24b2571dfa7e.tar.gz
boost-1.36.0: disable boost-serialization, it fails on powerpc
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost-36.inc22
-rw-r--r--packages/boost/boost_1.36.0.bb2
2 files changed, 11 insertions, 13 deletions
diff --git a/packages/boost/boost-36.inc b/packages/boost/boost-36.inc
index 62dc504b84..3ccb66f4b6 100644
--- a/packages/boost/boost-36.inc
+++ b/packages/boost/boost-36.inc
@@ -22,16 +22,24 @@ BOOST_LIBS = "\
iostreams \
program_options \
regex \
- serialization \
signals \
system \
test \
thread \
"
+# FIXME: for some reason this fails on powerpc
+#BOOST_LIBS += "serialization"
+
+# To enable python, uncomment the following:
+#BOOST_LIBS += "python"
+#DEPENDS += "python"
+#PYTHON_ROOT = "${STAGING_DIR_HOST}/${layout_prefix}"
+#PYTHON_VERSION = "2.5"
+
S = "${WORKDIR}/${BOOST_P}"
-# Make a package for each library, plus -dev and -python
+# Make a package for each library, plus -dev
PACKAGES = "${PN}-dbg ${BOOST_PACKAGES}"
python __anonymous () {
import bb
@@ -54,16 +62,6 @@ FILES_boost-serialization = "${libdir}/libboost_serialization*.so* \
FILES_boost-test = "${libdir}/libboost_prg_exec_monitor*.so \
${libdir}/libboost_unit_test_framework*.so*"
-# Python - remove this and set:
-#PYTHON_ROOT = "/dev/null"
-# to remove the python build
-DEPENDS += "python"
-PYTHON_ROOT = "${STAGING_DIR_HOST}/${layout_prefix}"
-PYTHON_VERSION = "2.5"
-
-PACKAGES += "boost-python"
-FILES_boost-python = "${libdir}/libboost_python*.so*"
-
# -dev last to pick up the remaining stuff
PACKAGES += "${PN}-dev"
FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so ${libdir}/libboost_*.a"
diff --git a/packages/boost/boost_1.36.0.bb b/packages/boost/boost_1.36.0.bb
index fdc3136ac4..17fddb06b4 100644
--- a/packages/boost/boost_1.36.0.bb
+++ b/packages/boost/boost_1.36.0.bb
@@ -2,7 +2,7 @@ include boost-36.inc
DEFAULT_PREFERENCE = "-1"
-FILE_PR = "r2"
+FILE_PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
file://arm-intrinsics.patch;patch=1 \