summaryrefslogtreecommitdiffstats
path: root/packages/boost
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-09-21 14:38:45 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-09-21 14:38:45 +0000
commit653773873c33648dc59a626f4cdec44f68851832 (patch)
tree46bcd6a445e350bb60fea20013b7bee29340e698 /packages/boost
parent0976ac4adbe43aa25e910c086d68485dcdb64651 (diff)
downloadopenembedded-653773873c33648dc59a626f4cdec44f68851832.tar.gz
boost 1.34.1: Create proper library files to fix packaging.
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost_1.34.1.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/packages/boost/boost_1.34.1.bb b/packages/boost/boost_1.34.1.bb
index 68afcafea5..712bb6c566 100644
--- a/packages/boost/boost_1.34.1.bb
+++ b/packages/boost/boost_1.34.1.bb
@@ -15,7 +15,7 @@ SRC_URI = "\
file://${PV}-gcc43.patch;patch=1 \
"
-PR = "r0"
+PR = "r1"
BJAM_TOOLS = "--toolset=gcc \
'-sGCC=${CC} '${BJAM_CONF} \
@@ -39,3 +39,14 @@ do_configure() {
echo "import toolset : using ;" > tools/build/v2/user-config.jam
echo "using gcc : : ${CC} : <cflags>${CFLAGS} <cxxflags>${CXXFLAGS} <linkflags>${LDFLAGS} ;" >> tools/build/v2/user-config.jam
}
+
+do_install_append() {
+ # Since boost does not provide library files in the form
+ # lib<name>.so.<abi> and a symlink pointing to this file
+ # we need to do this manually.
+ for F in `find ${D}${libdir} -name "*.so" -maxdepth 1`; do
+ echo renaming $F to $F.${PV}
+ mv $F $F.${PV}
+ ln -sf `basename $F`.${PV} $F
+ done
+}