aboutsummaryrefslogtreecommitdiffstats
path: root/packages/brickout
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/brickout
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/brickout')
-rw-r--r--packages/brickout/brickout_2002.06.09.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/brickout/brickout_2002.06.09.bb b/packages/brickout/brickout_2002.06.09.bb
index e69de29bb2..c3d1da6712 100644
--- a/packages/brickout/brickout_2002.06.09.bb
+++ b/packages/brickout/brickout_2002.06.09.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Clone of the classic arcade game Asteroids for Qt/Embedded based palmtop environments w/ SDL"
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "libsdl-qpe libsdl-mixer libsdl-image"
+PR = "r4"
+
+SRC_URI = "ftp://ftp.sonic.net/pub/users/nbs/unix/agenda/brickout/src/brickout-${PV}.tar.gz \
+ file://directories.patch;patch=1"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += " INCLUDEPATH+=${STAGING_INCDIR}/SDL LIBS+=-lSDL LIBS+=-lSDL_mixer LIBS+=-lSDLmain \
+ LIBS+=-lSDL_image LIBS+=-lpthread TARGET=brickout DEFINES+=USE_SDL "
+
+do_configure_prepend() {
+ qmake -project -o brickout.pro
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/share/brickout/sounds \
+ ${D}${palmtopdir}/share/brickout/music \
+ ${D}${palmtopdir}/share/brickout/images
+ install -D -m 0755 brickout ${D}${palmtopdir}/bin/brickout
+ install -D -m 0644 brickout.png ${D}${palmtopdir}/pics/brickout.png
+
+ cp -a sounds/* ${D}${palmtopdir}/share/brickout/sounds/
+ cp -a music/* ${D}${palmtopdir}/share/brickout/music/
+ cp -a images-sdl/* ${D}${palmtopdir}/share/brickout/images/
+
+ echo "[Desktop Entry]" >${D}${palmtopdir}/apps/Games/brickout.desktop
+ echo "Comment=Arkanoid game" >>${D}${palmtopdir}/apps/Games/brickout.desktop
+ echo "Exec=brickout" >>${D}${palmtopdir}/apps/Games/brickout.desktop
+ echo "Icon=brickout" >>${D}${palmtopdir}/apps/Games/brickout.desktop
+ echo "Type=Application" >>${D}${palmtopdir}/apps/Games/brickout.desktop
+ echo "Name=Brickout" >>${D}${palmtopdir}/apps/Games/brickout.desktop
+}