aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bt950-cs
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/bt950-cs
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/bt950-cs')
-rw-r--r--packages/bt950-cs/bt950-cs_0.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/bt950-cs/bt950-cs_0.1.bb b/packages/bt950-cs/bt950-cs_0.1.bb
index e69de29bb2..9da0752656 100644
--- a/packages/bt950-cs/bt950-cs_0.1.bb
+++ b/packages/bt950-cs/bt950-cs_0.1.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Linux driver for OX16C950 UART Bluetooth cards"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.holtmann.org/linux/bluetooth/bt950.html"
+DEPENDS = "pcmcia-cs"
+RDEPENDS = "pcmcia-cs"
+
+SRC_URI = "http://www.holtmann.org/linux/bluetooth/bt950-${PV}.tar.gz \
+file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/bt950-${PV}"
+
+PACKAGES = "kernel-module-bt950-cs"
+FILES_kernel-module-bt950-cs = "/etc/pcmcia/bt950.conf /lib/modules/${KERNEL_VERSION}/kernel/drivers/bluetooth/bt950_cs.o"
+
+inherit module
+
+do_install() {
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/bluetooth/ \
+ ${D}/${sysconfdir}/pcmcia/
+ install -m 0644 bt950_cs.o ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/bluetooth/
+ install -m 0644 bt950.conf ${D}/${sysconfdir}/pcmcia/
+}
+
+pkg_postinst() {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+update-modules || true
+}
+
+pkg_postrm() {
+#!/bin/sh
+update-modules || true
+}
+