aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cairo
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-02-13 00:51:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-13 00:51:38 +0000
commit56901f00366e56b1a25b0d2d02f8a8fbc6e2b87e (patch)
tree530ad8fdae94dd9f46d4fcaa285b406ebe394086 /packages/cairo
parent70774a74a42e8c657b73f375e3273ad7be7681f1 (diff)
downloadopenembedded-56901f00366e56b1a25b0d2d02f8a8fbc6e2b87e.tar.gz
libsvg: Add 0.1.4 thanks to Eric Shattow (shadows) (#675)
Diffstat (limited to 'packages/cairo')
-rw-r--r--packages/cairo/libsvg-0.1.4/.mtn2git_empty0
-rw-r--r--packages/cairo/libsvg-0.1.4/gcc4_and_expat.patch19
-rw-r--r--packages/cairo/libsvg_0.1.4.bb17
3 files changed, 36 insertions, 0 deletions
diff --git a/packages/cairo/libsvg-0.1.4/.mtn2git_empty b/packages/cairo/libsvg-0.1.4/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cairo/libsvg-0.1.4/.mtn2git_empty
diff --git a/packages/cairo/libsvg-0.1.4/gcc4_and_expat.patch b/packages/cairo/libsvg-0.1.4/gcc4_and_expat.patch
new file mode 100644
index 0000000000..feec4ab74d
--- /dev/null
+++ b/packages/cairo/libsvg-0.1.4/gcc4_and_expat.patch
@@ -0,0 +1,19 @@
+diff -bur libsvg-0.1.4~orig/src/svg_parser_expat.c libsvg-0.1.4/src/svg_parser_expat.c
+--- libsvg-0.1.4~orig/src/svg_parser_expat.c 2005-02-14 11:26:26.000000000 -0600
++++ libsvg-0.1.4/src/svg_parser_expat.c 2006-02-10 21:58:20.000000000 -0600
+@@ -30,6 +30,7 @@
+ #include "svgint.h"
+ #include "svg_hash.h"
+
++#ifndef LIBSVG_EXPAT
+ static void
+ _svg_parser_sax_start_element (void *closure,
+ const XML_Char *name,
+@@ -43,6 +44,7 @@
+ _svg_parser_sax_characters (void *closure,
+ const XML_Char *ch,
+ int len);
++#endif
+
+ static void
+ _svg_parser_sax_warning (void *closure,
diff --git a/packages/cairo/libsvg_0.1.4.bb b/packages/cairo/libsvg_0.1.4.bb
new file mode 100644
index 0000000000..77d86c7674
--- /dev/null
+++ b/packages/cairo/libsvg_0.1.4.bb
@@ -0,0 +1,17 @@
+SECTION = "libs"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+DEPENDS = "expat jpeg zlib libpng"
+DESCRIPTION = "SVG parser library"
+PR = "r0"
+
+SRC_URI = "http://cairographics.org/snapshots/libsvg-${PV}.tar.gz \
+ file://gcc4_and_expat.patch;patch=1"
+
+EXTRA_OECONF = "--with-expat"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all()
+}