aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cdparanoia
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/cdparanoia
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/cdparanoia')
-rw-r--r--packages/cdparanoia/cdparanoia_9.8alpha.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/cdparanoia/cdparanoia_9.8alpha.bb b/packages/cdparanoia/cdparanoia_9.8alpha.bb
index e69de29bb2..2c81cfb61d 100644
--- a/packages/cdparanoia/cdparanoia_9.8alpha.bb
+++ b/packages/cdparanoia/cdparanoia_9.8alpha.bb
@@ -0,0 +1,27 @@
+# cdparanoia OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+LICENSE="GPL"
+
+SRC_URI="http://downloads.xiph.org/releases/cdparanoia/cdparanoia-III-alpha9.8.src.tgz \
+ file://fixes.patch;patch=1"
+
+S="${WORKDIR}/cdparanoia-III-alpha9.8"
+
+inherit autotools
+
+do_install() {
+ oe_runmake BINDIR="${D}usr/bin" MANDIR="${D}usr/share/man/" \
+ INCLUDEDIR="${D}usr/include/" LIBDIR="${D}usr/lib" install
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}
+
+ install -m 0644 paranoia/cdda_paranoia.h ${STAGING_INCDIR}
+ install -m 0644 interface/cdda_interface.h ${STAGING_INCDIR}
+
+ oe_libinstall -C interface libcdda_interface ${STAGING_LIBDIR}
+ oe_libinstall -C paranoia libcdda_paranoia ${STAGING_LIBDIR}
+}