aboutsummaryrefslogtreecommitdiffstats
path: root/packages/cdump
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/cdump
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/cdump')
-rw-r--r--packages/cdump/.mtn2git_empty0
-rw-r--r--packages/cdump/abiword-2.0.12/.mtn2git_empty0
-rw-r--r--packages/cdump/abiword-2.0.12/cdump.c110
-rw-r--r--packages/cdump/cdump-native.bb17
4 files changed, 127 insertions, 0 deletions
diff --git a/packages/cdump/.mtn2git_empty b/packages/cdump/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cdump/.mtn2git_empty
diff --git a/packages/cdump/abiword-2.0.12/.mtn2git_empty b/packages/cdump/abiword-2.0.12/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/cdump/abiword-2.0.12/.mtn2git_empty
diff --git a/packages/cdump/abiword-2.0.12/cdump.c b/packages/cdump/abiword-2.0.12/cdump.c
index e69de29bb2..4089690222 100644
--- a/packages/cdump/abiword-2.0.12/cdump.c
+++ b/packages/cdump/abiword-2.0.12/cdump.c
@@ -0,0 +1,110 @@
+/* AbiSource Build Tools
+ * Copyright (C) 1998 AbiSource, Inc.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ * 02111-1307, USA.
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+
+long _getFileLength(const char* pszFileName)
+{
+ long iLengthOfFile;
+
+ FILE* fp = fopen(pszFileName, "rb");
+ if (!fp)
+ {
+ return -1;
+ }
+
+ if (0 != fseek(fp, 0, SEEK_END))
+ {
+ fclose(fp);
+
+ return -1;
+ }
+
+ iLengthOfFile = ftell(fp);
+
+ fclose(fp);
+
+ return iLengthOfFile;
+}
+
+long _readEntireFile(const char* pszFileName, unsigned char* pBytes, unsigned long iLen)
+{
+ FILE* fp = fopen(pszFileName, "rb");
+
+ if (!fp)
+ {
+ return -1;
+ }
+
+ if (iLen != fread(pBytes, 1, iLen, fp))
+ {
+ fclose(fp);
+
+ return -1;
+ }
+
+ fclose(fp);
+
+ return iLen;
+}
+
+void _dumpHexCBytes(FILE* fp, const unsigned char* pBytes, long iLen)
+{
+ long i;
+
+ for (i=0; i<iLen; i++)
+ {
+ if (i
+ && ((i % 16) == 0))
+ {
+ fprintf(fp, "\n");
+ }
+
+ fprintf(fp, "0x%02x,", pBytes[i]);
+ }
+
+ fprintf(fp, "\n");
+}
+
+int main(int argc, char** argv)
+{
+ long iLen;
+ unsigned char* pBytes;
+
+ if (argc != 3)
+ {
+ fprintf(stderr, "Usage: %s datafile arrayname\n", argv[0]);
+
+ return -1;
+ }
+
+ iLen = _getFileLength(argv[1]);
+ pBytes = malloc(iLen);
+
+ _readEntireFile(argv[1], pBytes, iLen);
+
+ printf("unsigned char %s[] = {\n", argv[2]);
+ _dumpHexCBytes(stdout, pBytes, iLen);
+ printf("};\n");
+
+ printf("unsigned long %s_sizeof = sizeof(%s);\n",argv[2],argv[2]);
+
+ return 0;
+}
diff --git a/packages/cdump/cdump-native.bb b/packages/cdump/cdump-native.bb
index e69de29bb2..e2d8263228 100644
--- a/packages/cdump/cdump-native.bb
+++ b/packages/cdump/cdump-native.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Cdump tool from abiword - needed for building abiword"
+inherit native
+
+S = ${WORKDIR}/abiword-2.0.12/
+SRC_URI = "file://abiword-2.0.12/cdump.c"
+
+do_compile() {
+ gcc -o cdump cdump.c
+}
+
+do_stage() {
+ install -m 755 cdump ${STAGING_BINDIR}
+}
+
+do_install() {
+ true
+}